Jump to content

[Resolved] Spotlights not working for A320X v4.1


Aidan Hutchison

Recommended Posts

Aidan Hutchison

I've installed the new version of spotlights as administrator, I've got dynamic lighting enabled, and I've disabled windows defender as well, however all lights that use spotlights in the cockpit do not work. I've tested with hdr on, off, msaa, and no aa at all. I've also tried reinstalling spotlights. I've got an RX 480 card running 17.7.1 radeon drivers. Thanks.

Link to comment
James Holland Jr.

Having the same problem.  Spotlight is not working.  Litterally been trying to figure this out all damn day.  Very frustrated.  Installed/uninstalled this thing about a hundred times...still no lights.  :(

Link to comment
Dean Johnston
11 hours ago, James Holland Jr. said:

Having the same problem.  Spotlight is not working.  Litterally been trying to figure this out all damn day.  Very frustrated.  Installed/uninstalled this thing about a hundred times...still no lights.  :(

Can you show me your XML file for the spotlights using the notepad?

 

Link to comment
James Holland Jr.

<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
  <AddOn.Name>Flight Sim Labs Spotlights</AddOn.Name>
  <AddOn.Description>FSLabs Spotlights. Publisher: Flight Sim Labs, Ltd.</AddOn.Description>
  <!-->DLL Components</-->
  <AddOn.Component>
    <Name>FSLabs Spotlights Module</Name>
    <Category>DLL</Category>
    <Path>DLLs\FSLSpotlights_P3D_x64.dll</Path>
    <DLLType>PDK</DLLType>
  </AddOn.Component>
  <!-->Effects</-->
  <AddOn.Component>
    <Category>Effects</Category>
    <Path>Effects</Path>
  </AddOn.Component>
</SimBase.Document>
 

Link to comment
Lefteris Kalamaras

In 99% of the cases it is the antivirus blocking some folders.

(Your P4D Add-on Folder)\FSLabs
(Your P4D Add-on Folder)\Spotlights
C:\ProgramData\FlightSimLabs\LAAS
 

Exclude those (making sure subfolders are also excluded) in your antivirus settings and let us know.

 

Link to comment
Kadiyala Satyanvesh

Just an update, SpotLights is working again after disabling Windows Defender.

Fly safe


Sent from my iPhone using Tapatalk
How you disabled windows defender. Any steps or link if possible?

Sent from my SM-C900F using Tapatalk

Link to comment
Valentin Rusu

Excluded all from windows defender, still does not work for me. This update for 4.1 gave me so many frustrations regarding install. First was not showing up in the menu, now the Spotlights... never experienced these issues with the other aircraft addons which I am using in 4.1... 

Hopefully I can get it sorted out in the end... but I was just saying, really frustrating this time. I did not have these issues with v3...

Edit: Solved it. Why the installs are still doing this mess in the add-ons.cfg?

[Package.0]
PATH=F:\Lockheed Martin\Prepar3Dv4_Addons\FSLabs
TITLE=FSLabs Aircraft Family
ACTIVE=true
REQUIRED=false
[Package.0]
PATH=F:\Lockheed Martin\Prepar3Dv4_Addons\Spotlights
TITLE=FSLabs Spotlights
ACTIVE=true
REQUIRED=false
[Package.1]
PATH=F:\Lockheed Martin\Prepar3Dv4_Addons\FSLabs
TITLE=FSLabs Aircraft Family
ACTIVE=true
REQUIRED=false

 

Link to comment

I had to completely disable real-time protection on my Windows. Defender has never been running either. Seems to work now, but would like to know how to keep the spotlights working with real-time protection turned on. Hmm

Link to comment
James Holland Jr.
Just now, craiggear said:

This is apparently normal. 

Well I will tell you what is not normal......Paying $139.99 for an virtual airplane .  Then feeling "virtually" raped.  When the add on product is not working, as intended.  Might have to rethink the next purchase from FSLabs.....don't know about anyone else.  But I don't have a buck 40 just to pitch out randomly, and shit not work.  Long term simmer, from the days of Microsoft FS1980, lol, til now.  Not what I expect......but somehow the program that takes our money never fails:unsure:

  • Like 1
Link to comment
Lefteris Kalamaras

James-

if you haven't yet, please open a support ticket and I'll personally help you out via a remote Teamviewer session.

I would also appreciate a change of language tone because it really does not help when you insult others.

  • Like 1
Link to comment
James Littler

All,

I have the same problem. Installed the latest version 2.0.0.2 today. P3d V4.1 crashed upon load even with the default aircraft. Went back to 2.0.0.1 P3D v4.1 starts but no spotlights still. I have disabled Windows Defender and excluded all the folder as suggested with no luck.

JJ

Link to comment

P3Dv4, Spotlights v2.0.0.1

If Spotlights is installed correctly and you see the little icon, but don't see any Spotlights lights, try this ...

1. Start P3Dv4, load a plane and airport AT NIGHT.

2. Start the Spotlights Manager and let it connect to P3D.

3. Create a group and add Lamp #0. Set the X-axis to 0.0, brightness to 100% and choose RED as the nighttime lamp color. UNCHECK "VC only."

4. Go outside the plane and pan around looking for a RED color bleeding thru the fuselage. If you don't see anything try increasing the Outer Angle of Lamp #0 or CHECK "Overbright".

5. Once you find where the light is, use the Z-axis to move the light source forward (positive number) or backward (negative number) until you get the desired position.

On the CRJ700 (sorry I don't have the FSL320X) I had to move the Z-axis forward about 35-40 feet. Good luck.

Link to comment
James Holland Jr.
20 hours ago, Lefteris Kalamaras said:

James-

if you haven't yet, please open a support ticket and I'll personally help you out via a remote Teamviewer session.

I would also appreciate a change of language tone because it really does not help when you insult others.

Explain to me who is the others?.....let me help you....there is no others. One person/organization/whoever.  You can take the tone any way you want(I meat it as a statement). It speak fact fact. What is insulting is putting out a product with way too many bugs.  I can understand a hick up here and there. But to out right not work is in fact appalling by its self.  Weather I tell you or the tech makes no difference either or. But I know I am not the only one here thinking the same thing. So solution....fix the problem in this current firmware.....so we can fully enjoy out $139.99 plus an additional $19.99 depends on who’s talking. Lol

Link to comment
Reinhard Kummer

my problem.

Domlights and Floodlights not working. I reinstall Spotlights. Start Sim and All Lights are working fine. Next day, I start the Sim and Domlight and Floodlight not working. And so one and one.

Link to comment
Lefteris Kalamaras

Please exclude c:\Programdata\Flightsimlabs\LAAS from your antivirus, as well as the Spotlights installation folder.

Let us know if that works for you.

4 hours ago, James Littler said:

Installed latest Ezdok 2.6.0.26... no change still not a single dome light or spotlight to be seen.

Did you clean up your camera configurations?

Link to comment
Anuwat Lehmann

I can confirm from my test result that disabled Real-Time Protection in Windows Defender Security Center solve Spotlight problem on P3Dv4.1 with A320 v2.0.1.215 and Spotlight v2.0.0.3. Exclusion in Windows Defender does not solve the problem for me. So every time I want to fly FSL A320 then I've to disabled Real-Time Protection, that's fine. But I hope FSL will solve this problem on the next version. Cheers. 

2017-10-29_1-16-39-583.jpg

Link to comment
  • Lefteris Kalamaras changed the title to [Resolved] Spotlights not working for A320X v4.1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...