Jump to content

[Resolved] - vPilot Spotlight


Recommended Posts

Hi Team

I have noticed that as soon as I launch vPilot after having loaded the A320, it crashes my fsx (fsx has stopped to work..., a Windows error).

This happens 'only' when I have Spotlights installed, it is not the case if I disinstall it (but then i cannot fly by night :). On the otherhand, vPilot works if loaded before changing (selecting) the plane, and that is the way to go for me now. It is just unfortunate when you close vPilot while flying (which you normally won't do, but can happen) because I wouldn't be able to relaunch it again... . It happens in LGAV but also outside. Haven't bought Spotlight righ now.

Have tryied it with vPilot1 and vPilot2, same error. Running vPilot as administrator.

It triggers me this error:

Nome dell'applicazione che ha generato l'errore: fsx.exe, versione: 10.0.62615.0, timestamp: 0x559f9a9a
Nome del modulo che ha generato l'errore: KERNELBASE.dll, versione: 10.0.14393.0, timestamp: 0x57898e34
Codice eccezione: 0xc0000002
Offset errore 0x000d96c2
ID processo che ha generato l'errore: 0x325c
Ora di avvio dell'applicazione che ha generato l'errore: 0x01d20d553a9e2321
Percorso dell'applicazione che ha generato l'errore: D:\SteamLibrary\steamapps\common\FSX\fsx.exe
Percorso del modulo che ha generato l'errore: C:\Windows\System32\KERNELBASE.dll
ID segnalazione: 45acfb54-b0a8-4351-8f06-baab01fff17e
Nome completo pacchetto che ha generato l'errore:
ID applicazione relativo al pacchetto che ha generato l'errore:

Normally I am running fsx, Opus.

Spotlight Ver:

Am I the only one experiencing this?


(edited - corrected Title)

Link to comment
Lefteris Kalamaras

Can you give me concrete steps to reproduce this? I have vPilot v2 installed and have not noticed this behavior.

Could it be attributed to Opus instead? (There were people reporting issues with Opus). Try with Opus removed and see if that still happens...

Link to comment


I start up in this sequence: fsx (which also loads Opus on startup, exe.dll), trike, set myself on the airport. I then load A320 - fsx is running everything loaded. I then start vPilot (1 or 2 - have tried with both) and I sudden get the error (fsx has stopped working..). I have tested the whole sequence without spotlight (uninstalled it) and everything run fine and I can start vPilot without error afterwards (Opus still loaded), that’s why I suspected spotlight.

In fact I've only noticed this after having installed spotlight, which I discovered later being necessary for your beautiful A320 (@ night...). Had flown several flight before this, with vPilot and Opus running, lunching them in every sequence without any problem so far. Hence I just suspect there is something strange going on once spotlight is running and I afterwards start vPilot (as admin), at last on my rig.

fsx, opus, any ac, start vpilot - good
fsx, opus, start vpilot, change to A320 - good
fsx, opus, any ac, in fsx then change to A320, start vpilot - no good.
fsx, opus, any ac, in fsx then change to A320 (without spotlight/uninstalled), start vpilot - good
fsx, no opus, any ac, in fsx then change to A320, start vpilot - haven't tried. I may test this, but I can't imagine flying without Opus…

Win10, fsx-se, legacy simconnects installed.


Link to comment
Lefteris Kalamaras

Thank you for reporting back, but you reported back without actually following up on my recommendation to try without Opus (until we can detect that it 's NOT that).

Link to comment


Just tested now, running fsx without Opus:
fsx, no opus, any ac, in fsx then change to A320, start vpilot - no good.
fsx, opus, any ac, then change to PMDG 737 (with spotlight,  demo ini) @ LGAV (day time fs), start vpilot - no good
fsx, no opus, any ac, then change to PMDG 737 (with spotlight demo ini) @ LGAV (day time fs), start vpilot - no good

With no good i mean i get the same error as above in my first post

Uninstalled Spotlight, it works (even with Opus running)

To me, there is something wrong in spotlight... (running ver, not necessarly related to the A320, since i get the error even with the PMDG or on the other way I am able to start vPilot after having choosen the A320 if I uninstall spotlight.



Link to comment


hm, everything on the same machine, if you are asking this, and yes vPilot is an additional exe that you start. vPilot installs itself on his given path (as far as i know you cannot choose another path), whereas i have fsx is on a second disk. Haven't any special tweaks in my fsx.cfg

Win10, fsx-se, fsx.cfg attached



Link to comment

Hi Team

Have found out what the problem was/is. I have to turn out UAC on my Windows. If i turn out UAC everthing is running well, no crash!

I have to use vPilot as Admin, since I use a key on the keyboard for talking. The only strange thing, at last on my rig, is that I've to turn it out since I installed Spotlight, but this is not a big deal. Thank you very much for this great Add-On - now back on the deck :)


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...