Jump to content

[Resolved] Crashes on startup with Aerosoft Airbus in Prepar3D v3.3.5


slopey

Recommended Posts

I have just recently download the demo to try this out, however upon loading the aircraft it crashes my sim. I am using Prepare3D v3.3.5 with Aerosoft Airbus A320 1.31f. Not sure what is causing this to crash but it seems to be working fine with my other aircrafts. I am not using any 3rd party shader tools or PTA either. So I'm not sure what it may be. I hope there is a fix because this seems like a nice add-on that I would like to purchase to be used with all my aircrafts. Question now is what's causing the crash?

Link to comment
Lefteris Kalamaras

I do not own that aircraft, but I recall there is a related setting somewhere in their configurator for display drawing mechanism (Direct2D or something like that). Once you disable it, things work fine.

Link to comment
Daniel Du Preez

I have this problem as well with Aerosoft A320 series in P3D 3.3.5 with hotfix.  I get a CTD when loading the aircraft.  The latest version of FSL Spotlights is installed and I have confirmed that I have ECAM software rendering disabled in the Airbus configurator.  Other aircraft load absolutely fine without CTD.

- Prepar3D 3.3.5 with hotfix

- FSL Spotlights v1.0.0.22

- Aerosoft A18/319/320/321 v1.31

- Windows 10 Pro 64-bit

If I uninstall FSL Spotlights the issue is not reproducible.  For now I've removed the entry from the P3D dll.xml file as I don't use FSL Spotlights for anything else but once the P3D version of the A320 drops or I decide to pick up the Concorde that may change.

Link to comment
  • 2 months later...
Lothar Gentzsch

It  would be very nice to explain the solution " enable the software rendering"  and bring light into that . Where can I do that step ? I have still the Aerosoft A320 crash in P3D with FSLSpotlight Biuld 25.

Thanks

Lothar

Link to comment
Lothar Gentzsch

Unfourtunatly I have to disagree, sorry, this option is still "on"  but the P3D crashed furthermore . As I wrote in another post, I uncheck Build 25 from P3D. So long

Lothar

Link to comment
Lothar Gentzsch

I`m using Package A318/A319   and Package A320/A321. No shader add-ons in use. The decsribed crash problem ist independant on my desktop with WIN7 and on my Laptop with WIN10.

Regards

Lothar

Link to comment
Lothar Gentzsch

Lefteris, thanks for your kindly support. But before you spend your valuable time with me on Teamviewer let me do follow workaround: I`ll deinstall all Aerosoft Airbusses from P3D. Because I suggest a problem into Aerosoft area. I had installed - but now deinstalled already- the Beta of A318 Research. It`s a new product in testing. It seem that D2D - issues appeare in forum thread . Maybe some debris om my pc`s has to be removed with a cleaning.  Then I will reinstall the Aerosoft Busses and FSLSpotlight Build 25.Thereafter I will report the results here.

Thanks Lothar

Link to comment
Lothar Gentzsch

Hello Lefteris, after spent some hours with trouble shooting here is my report:

I`ve removed all Aerosoft Busses in P3D and FSX (!)  with all folder and dates in App Data, Shader etc.) and Spotlight Build 25. Then I did a clean run with a tune up tool.Therafter it was necessary in FSX to deinstall and reinstall the FSL A320X Binaries and Spotlight B 25. After a Shaderremoval in FSX the FSL Bus and Spotlight works fine on a testflight. Now I reinstalled the AEROSOFT A320 in P3D.   The default aircrafts and PMDG B738 run without trrouble. Now I load the Aerosoft A320 with active Force ECAM Software Rendering . The P3d crashed directly as before. The next test with the Airbus loading  with unchecked Force ECAM Software Rendering shows  the  P3D remain stable. But the lower ECAM remain fully dark. The Bus is unusable. The way only for use my Bus in P3D is to uncheck Spotlight in P3D. Or is a exclusion of the Aerosoftbusses in Spotlightsoftware possible ? 

Lothar

 

 

Link to comment
Lothar Gentzsch

In use is the Gigabite Geforce Nvidia GTX760 , with Driver Version Geforce 375.95 ( newest). DX11 is displayed, I don`t no how to check an older DX10 compatibillity.

Mabe some special adjustments in Nvidia Profile Inspector are nescessary, but wich one ?

The best way at the moment is to uncheck Spotlight for P3D, because I don`t use its  for another airplanes in P3D. After your relase the FSLA320x in P3D we have to see whats going on. You know I got the same problem on my new Acer Laptop  with new WIN10 and a new graphics card. I`ll bring this conflict to inform Aerosoft for further investigation

.For me is that the second conflict with FSLab. The first was the crash with the Soundtream programm in FSX. Only a deinstallation of Soundstream was a temporary solution. I love your A320x but its attacked another addons and need rectifications, its a pity. Let`s hope you get it in near future.

Regards

Lothar

Link to comment
Lefteris Kalamaras

Wait a minute-

you're blaming the A320-X for crashes that Soundstream is causing. Sorry, but I have to defend the A320-X here, as there are TONS of other reports that SoundStream was causing problems. So much so, that it got fixed :). (They had a crash to desktop bug themselves).

As for P3D and the Aerosoft software, I have tried it here and it does NOT crash, as long as you "Force ECAM Software Rendering" for it.

Link to comment
Lothar Gentzsch

Hi Lefteris,

yes, I agree, thats what I said some month ago. I detected that SoundStream with the A320X caused a FSX crash and a deinstallation of it got the solution.

Relating the Aerosoft software:

I`ve made some adjustments in Nvidia Profile Inspector and P3D itself without better performance - with Spotlight got a P3d Crash caused from software for the lower Ecam in combination with Spotlight.

But we can finish this thread. I`m using the Aerosoft aircrafts in P3D with deactivation of Spotlight dll`s (  make .offdll).  Thats my "personal switch".   After release of your FSLA320 in P3D I`ll reset to operate.

Now I have to live with this trick, it`s a pity, but what should I do ?

      Best Regards

Lothar

Link to comment
Lefteris Kalamaras

You don't have to live with this trick - every other person running the Aerosoft Airbuses has no issues once they "Force ECAM Software Rendering" to true (box checked). I can't really have a clue why their code would produce a problem in your particular instance alone - I've tried contacting them about it and they refused to acknowledge the issue anyway... so...

Link to comment
  • 4 weeks later...

The Aersoft Airbus A320/321 does not have the option for ECAM Rendering. Is there another way to fix that? I had the same problem for now.  If I load a default aircraft it works smooth, but as soon as I do change of fleet it crashes.

Also is it good to load Spot light before launching P3D? 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...