Jump to content

'FSL Spotlights Error'


AeroDan

Recommended Posts

Hi everyone,

I have already tried the fix in the FAQ, using that registrar .exe file, but to no avail. I have had to reinstall FSL Spotlights several times as my FSX will not start with it being problematic. The complete error message reads, 'FSLSpotlights was not initialized correctly. Please restart the simulator. If the problem persists, you need to reinstall the FSL Spotlights utility'. 

This is the message I get almost every time when starting up FSX and it's become very frustrating. This is the freeware FSLSpotlights.

Cheers,

Dan

Link to comment
On 8/24/2016 at 11:04 PM, Bob L said:

Can you provide more info - what is your OS version and what specific sim (FSX, FSX SP2, FSX Accel pack) version are you using?

My OS is Windows 7 and using stock FSX.

Link to comment

Are you using SweetFX, or Reshade or any shader add-on?  If so, please disable them. 

Since you're on Win7, do you have the Win7 SP1 Update installed?  And the Win7 SP1 Platform update installed as well?

 

Link to comment

Hello,

I have the same problem. I get an error when starting FSX. Installed it like 4 times. Still the same problem. The tips in the FAQ didn`t work for me. I`m on Windows 7, FSX SP2.

Would be glad if somebody had an answer.

Martin

Link to comment
Lefteris Kalamaras

The really long time is because you have a gazillion WOAI or other AI models installed?

Try removing them temporarily to see if that works. If that's the case, we'll do a workaround for you.

Link to comment
Andrea Bianchini

Ivao Mtl and vatsim models are very heavy on fsx loading. Just try for a moment to disable them from fsx.cfg simobject line.

Inviato dal mio iPad utilizzando Tapatalk

Link to comment

Hello,

unfortunately I still get the same error message. It doenst`t take that long for the FSX to start. I get the error message after about a minute. Don`t think the vatsim models are the problem. Can`t remember having ever installed another shader. Any idea what the problem is? Thanks for your help.

 

Martin

Link to comment
Lefteris Kalamaras

That large delay in starting FSX is the problem (which is a Spotlights issue, really, not your fault). However, if you want to try and remove those models to decrease the time FSX takes to load, we can see if that helps you for now (until I can come up with a better solution).

Link to comment

I have the same issue. FSLabs service never wants to start. It works the first couple of times after an install of the utility but then it craps out and every time I start P3D I get this message. Nothing I have seen on the forums corrects this issue. Yes, I am on version.22, No, I have no addon shaders.

 

Signed,

Frustrated.

Link to comment
Lefteris Kalamaras

"The same issue" is the FSLService stopping or the crash of Spotlights?

Trust me, this is frustrating for us as well, because we'd like nothing more than to fix the problem, but to do that, we need to keep our cool and actually find what's wrong. At the moment, other than a "Frustration" message, I am not getting any details on what could be causing it, so we can fix it.

Link to comment

What happens is a get a message that the FSLService did not start and that I would have to restart P3D. Then I get the Scenario screen and a background window like the sim is loading. In Other Words it is almost like 2 simultaneous instances of P3D is starting. I Have to wait until it allows me to click on the X in the Scenario screen to get out of the sim. Then I Have to go in to services and manually start the service. I have set the service to try and recover itself but I don't see that happening. This happens every time I start P3D.

 

Link to comment
Lefteris Kalamaras

If the FSLService is dying this is abnormal - it should not happen unless something in your computer is either causing it to crash or something is actively killing it - usually a trigger happy antivirus.

Can you please tell us if this continues if you disable the antivirus for a session from start of the PC until shut down?

Link to comment

I have the same issue too. Running FSX Stock on Windows 10 and Eset smart security with a couple addons:

- DX10 Scenery Fixer

- Active sky cloud art

- Active sky next

- FSDG Nuuk & Paro

- FSDT Geneva, Honolulu, & GSX

- France VFR Rhone-Alpes & French Island (Mesh et Photo textures)

- EZCA

- FSUIPC

- Only A320X (no other aircraft addons)

EVERYTHING was working fine yesterday evening, and I encountered this issue this morning. Trying the flight1 registry repair, reinstall FSL Spotlights, Reboot my machine, Switch from DX10 to DX9, then to DX10 ... Nothing!!

NB: This message appears 10 secs after launching FSX.

fsl error.jpg

Link to comment

It was already running :(

FSX can't start with this error. The only to have FSX working for now is to uninstall FSL Spotlights for me. But so, I can't fly with A320X by night :( .

Very disappointed. Hope you'll find a solution.

fsl error 2.jpg

Link to comment
Lefteris Kalamaras

I understand your frustration, but if things were working yesterday, but not today, then something on your computer changed and is affecting this.

Please think what that might be...

Link to comment

I'm 100% sure that I changed/touched nothing since yesterday to my computer, FSX, or whatever.

I opened the event viewer from windows --> No errors about FSL dlls or FSL services, FSX addons, or something that could be suspect.

I've tried to delete some FSLabs entries & keys in the registry, and reboot the computer --> nothing

Trying to disable/re-enable the FSLService --> nothing

Uninstalling A320X and FSLSpotlights, and cleared the fsx.cfg entries... and then reinstalling A320X & FSLSpotlights, and rebooting --> Nothing

The only thing that works is that when I uninstall FSLSpotlights --> So FSX works, but no spotlights for A320X

Edit: I also try to uninstall DX10 scenery fixer --> Still nothing

Link to comment
Lefteris Kalamaras

Torgy,

does it take a long time for FSX to load? (i.e. does it have lots of AI models?) - I know you listed your addons, but sometimes we forget that we installed, say, IvAp (which carries a bunch of MTL models). If so, can you temporarily remove them to see if that helps? (FSX should take no longer than 10-15 seconds to load).

Link to comment

No, FSX needs only 10 sec to start and show the error message, and a bit more like 12 sec for a succesful start with FSLSpotlights uninstalled.

 

FSX was just reinstalled for A320X, in the waiting for the P3D version, so I did not installed much addons, and as you ask, IVAO or VATSIM were not installed. I tried to find a solution all day... uninstalling things, addons, FSX, save/deleting/re entry lines in the registry,... one by one... and reinstalling all of it.... and still nothing!! Still the same error message. Even a clear install of FSX with simply FSLSpotlights cannot even start FSX correctly without this message.

 

So I've decided to format my Windows 10 and the disk where FSX was installed. I think at this point that the problem was not FSX or addons. Maybe there were some dependencies with FSLSpotlights or FSL services that were blocked because of other process or stuff like that. Since my first blue screens with windows 95 and my firsts takeoff on MSF98, there were a very few issues that I wasn't able to resolve, but this... I'm done. I hope this will work for now, but reinstalling all the drivers, antivirus and sims gonna take a long time for tonight. I'll be back to confirm in a few days (or a few hours) if the issue is resolved or if this shits come back to life and annoy me all day.

So I'll can tell you were the issue comes from ^^.

Best regards

NB: So, A320X was reinstalled 2 times since September 4th, I'll hope there will no activation iissue for the next install.

 

Link to comment
Lefteris Kalamaras

Don't worry, if there's any issues with activation limits, we'll reset them for you.

Also, if this issue with Spotlights continues afterwards, we'll do a Teamviewer session to debug on your end.

  • Like 1
Link to comment
C_r_i_s_t_i_a_nR_u_d_n_i_k

@Torgy, with a really clean installed FSX, try to install (and run) A320 and Spotlights with your security/antivirus software disabled.

Some people here got a false positive with Spotlights, so chances are there is something blocked. It´s worth to try this before you install all again !

Link to comment

@chris198 I've tried this today too. I have ESET Smart Security, and I there were nothing on the blacklist or quarantine. Absolutely no false positive with any FSLabs products.

For now, time to downloads some drivers and boot, reboot, rerererereboot before installing FSX ;)

EDIT: ATM, The windows 10 installation has failed (parameters button fail, unsolved by the startmenu.diagcab method... --> So Win10 is redownloaded for a new installation). :angry::angry::angry::angry::angry::angry::angry::angry::angry:.

Link to comment

I have the same issue - I don't get SpotLights to work. I've read the FAQ and everything is seems fine (version of dxgi.dll is ok, latest Windows Updates installed, latest .NET Framework installed, don't own VRS TacPack).

System:

  • Win7 64 Bit
  • i7 4790k
  • 16GB RAM
  • GTX980

What I've tried:

  • I've tried to use it in FSX:SE and in P3D v3.2 - doesn't work in any. I always get the FSLSpotlights was not initialized correctly message.
  • In FSX I've tried DX9 and DX10 - nothing
  • I've disabled all other dll.xml entries to see if any other module causes a conflict - nothing
  • I've completly removed ReShade - nothing
  • I've restarted the system several times, installed several times, nothing
  • I've tried with a clean cfg-file - nothing
  • Deleted the shader cache - nothing
  • Windows Event-Log contains no further information
  • I did not find any log-file for SpotLights

The only similarities between my FSX/P3D installation is FlyInside (but disabled for testing) and ReShade (also disabled). Its really annoying because I really want to fly the A320 at night but I am not really able to.

Link to comment
Lefteris Kalamaras

As I've mentioned in other threads, there's a known incompatibility with ReShade, so that's a given (the dxgi.dll or d3d9.dll should not be in the FSX root folder).

Once you're sure you've removed those, clear the shader cache and retry, with the latest 1.0.0.22 Spotlights.

Link to comment

I've already noticed your incompatibility notice before. I really made sure, that no dxgi.dll/d3d9.dll is inside the FSX root folder. (same with d3d11.dll in P3D)

I've also already tried version .22, deleted the shader cache, but still no luck.

Is there a debug-version available with detailed logging? Then I would be able to upload the log file.

Link to comment

Thanks for the offer - will send it to you as soon as possible (might be next week because I'll have a busy weekend and still have to make some preparations).

Just had an idea: I will create a small tool which displays the absolue path of the loaded d3d9.dll as soon as I get home this evening. Maybe I really forgot something. Will post the result here.

Edit: Ok, just checked the path of the loaded dlls and everything is fine - ReShade is completly disabled and the original d3d9.dll inside the Windows Folder is used.

Edit2: Lefteris Kalamaras found the problem during a remote debug session: I've moved my FSX to another drive and created a symlink to the new destination. The result is: the real file location of was different to the path stored inside the registry. So we changed the registry pointing now to the real folder and it works :D (remember to restart the FSLabs Service). So to anybody who has the same issue: fix your registry path(es), restart the FSLabs Service and see if it works now. Maybe FSLabs finds a way to get around this un-common configuration.

Link to comment
  • 1 month later...
On 9/15/2016 at 8:42 AM, littleDave said:

...

Edit2: Lefteris Kalamaras found the problem during a remote debug session: I've moved my FSX to another drive and created a symlink to the new destination. The result is: the real file location of was different to the path stored inside the registry. So we changed the registry pointing now to the real folder and it works :D (remember to restart the FSLabs Service). So to anybody who has the same issue: fix your registry path(es), restart the FSLabs Service and see if it works now. Maybe FSLabs finds a way to get around this un-common configuration.

I have a similar configuration where I created links to "C:\Program Files (x86)\Steam\steamapps\common\FSX" for steam and boxed (they reside in FSX-SE AND FSX-MS in the same path of FSX). I don't want to brake my installation, so I kindly request FSL  to verify the possibility for the installer to deal with such configuration. For information, Concorde-X installs fine. As of version 1.0.0.23, Spotlights does not accept this configuration. I had the same problems as littleDave.

Regards,

coffee

Link to comment
David Hüttig

As far I as remember correctly, the following did the trick for me:

Open your registry editor (regedit.exe) and navigate to the path
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft Games\Flight Simulator\10.0

You will find an entry called SetupPath. Change the value to the physical path location or FSX - NOT to the symlink. After that, restart the FSLabs Service, clear your shader cache and try to start FSX. Changing this value did not corrupt/change anything in FSX (at least for me) and I did not have any other problem.

I don't have the boxed version installed so this might look a little bit different.

  • Like 1
Link to comment

Thank you for the helpful explanation,

It worked for FSX-SE. The registry trick was only needed during installation. I then returned the registry to the original symbolic link and kept both versions working as before. Clearing the shader cache was truly necessary.

Regards,

coffee

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...