Jump to content

Cannot Find FSX


superfish

Recommended Posts

Yup, that fixed it.? However, is there any indication that the driver is working other than flying the aircraft?? Also, is this driver free because I didn't see anything about purchasing the software?

Thanks for your help.

Frank

Link to post
Lefteris Kalamaras

Frank-

information about purchasing the driver interface is clearly shown in the product details page here:

http://www.flightsimlabs.com/Interfaces/Go...tMCPProFSX.aspx

Once the driver detects that you have a valid hardware unit and you have used its interface to connect to the aircraft (at LGAV when in try-before-you-buy mode), a Purchase button becomes visible and you can use it to enter your credit card details etc. online.

Thanks for supporting us!

Link to post

Thanks for your reply.? I finally installed the driver software but many problems have ensued.? The following actions and system responses occured after installation.

1.? I changed my GoFlight setting for the MCP to "Compatible Addon."? I started FSX.? I loaded the airport ICAO code "LGAV."? The free flight loaded and the flightsimlabs link appeared in the menu drop-down box.? I clicked the link.? The menu displayed.? The purchase button was active.? When I clicked this button, FSX crashed to the desktop.

2.? I restarted FSX and again loaded the PMDG B744 and the "LGAV" ICAO airport code.? Again I selected the flightsimlabs link and clicked the "Purchase" button.? Again, FSX crashed.? This time I noticed that one of the selection boxes under "Serial connection" was checked.? I have no idea what the function of this selection has on the process but it was selected.? I have no serial comm connections to my computer.

NOTE:? During the two attempts to access the purchase link, my GoFlight hardware had problems with activation.? The MCP Pro no longer functioned and the other module functions were erratic.

3.? I restarted my computer.? I executed the GoFlight Configuration software and selected the MCP Pro device.? I changed the setting to FS Default.

4.? I started FSX and selected the default B738.? The aircraft loaded properly and my GoFlight hardware connected.? All my controls returned to normal including the MCP.? All software and hardware operated properly.? I took this step to determine if there was something wrong with my setup.? No problems were observed.

5.? With FSX still loaded, I changed the aircraft to the PMDG B744.? I again loaded the "LGAV" ICAO location.? I also changed my GoFlight configuration for the MCP Pro to "Compatible Addon."? Once again I accessed the flightsimlabs link for purchase.? This time the "Purchase" button was greyed out.? I tried this action twice with no change.? I now cannot access the "Purchase" link.? In addition, the MCP Pro was non-operational.

Thanks

Frank

SYSTEM:
Intel E6700 2Core CPU
EVGA 680i LT MOBO
EVGA 8800 Ultra graphics card
4Gb RAM (3Gb switch)
Liquid cooling by Thermaltake
Vista 32-bit OS
FSX

Link to post

Something I thought I should add - version 1.77 of the GoFlight configuration software does not work with Vista 32-bit and FSX - at least the data bridge?portion does not.? In order to get the configuration software to work with FSX, you have to download and install version 1.77.? Then you copy all the files to a separate folder.? Then you uninstall version 1.77.

After uninstalling the config software, you download and install the previous version - 1.74.? You have to move this version to a separate folder and uninstall version 1.74.? Then, re-install version 1.77 - delete the files you moved to a separate folder.

After re-installing version 1.77 you go? to the folder where you moved version 1.74 and copy the following files to the version 1.77 folder overwriting the files there:

GFDev.dll

GFDev2k2.dll

GFDev2k4.dll

GFDevFSX.ini

This method gives you version 1.77 of all the GoFlight software except the databridge files.? These files come from version 1.74.? These actions provide a workaround to Version 1.77's non-operation under Vista and FSX.? Note:? The only thing that doesn't work is the LED shutdown after closing FSX.? You have to execute and then shutdown GFCconfig.exe.

This workaround may be an issue with the flightsimlabs driver installation and operation.

Frank

Link to post
Lefteris Kalamaras

Frank-

can you please try to uninstall all the GoFlight software itself and see if you have better success with our interface? Also- make sure you are running with the latest firmware (A22) on the hardware.

Let us know!

Link to post

OK, my MCP Pro and EFIS modules are on their way to GoFlight for a firmware upgrade.? The GoFlight-Vista issue with the databridge has been fixed and will be in a new update coming soon.? So, when I get the modules back I'll check to see if I can then purchase the interface.

I did notice the interface software is showing up in the installed software list so at least I've gotten that far.

Frank

Link to post

OK, my MCP Pro and EFIS modules are back from GoFlight with their new firmware upgrades.? There were also some changes to the boards but I don't know what that entailed.? I also have a BETA version of a new GFDevFSX.exe program.? This new version operates properly with Vista and FSX.

Now, I started a flight with the PMDG B744 and accessed the flightsimlabs menu entry.? The "PURCHASE" button is still greyed out so there is no way I can purchase the interface.? What do I do now?

Thanks

Frank

Link to post

Yes.? The first time I attempted a purchase, the "Purchase" button became active and the system went into process activity but never actually connected.

I closed FSX and rebooted my system.? This time when I tried a purchase FSX crashed.? I had to disconnect my system from the power to get the OS back.

Frank

Link to post
Lefteris Kalamaras

There are a couple other forum posts where this problem (and its solution) is mentioned. It has to do with Vista and a feature called DEP.

Look at our Knowledge Base - it's mentioned there (along with the solution).

Hope that helps!

Link to post

OK, I addressed the DEP issue and now I have purchased the interface software.? I filled in the key menu and generated a key.? The instructions stated that I was to place the key in fsx\flightsimlabs folder.? However, when I installed the interface software the installer placed the software in c:\program files\flightsimlabs folder.

Inside the flightsimlabs folder is another folder - GoFlightMCPProX.

So, to cover all the bases, I placed the key in:

c:\program files\flightsimlabs

c:\program files\flightsimlabs\goflightmcpprox

c:\fsx\flightsimlabs

c:\fsx\flightsimlabs\goflightmcpprox

folders.

I set the GoFlight configuration to "FSX Compatibility."

I then executed FSX and loaded the PMDG B744.? The MCP Pro did not respond.? All the displays were dashes.

Now what do I do.

Frank

Link to post
Lefteris Kalamaras

Hi Frank-

the proper folder to place the license key is:

In your FSX folder (I assume it's c:\fsx), there's a subfolder called FSLabs. That's where you drop the license key file.

Then, you need to load the 744 and use the Add-ons menu, find the FSLabs GoFlight submenu and, in the dialog window, hit "Connect". Things should work fine from there.

Link to post

Sir,

First, let me thank you for staying with me through this procedure.? I'm quite sure that product support can be a pain - especially when the user can't see very well.

I finally placed the key in the correct folder and the whole problem went away.? Now I can use my hardware with the aircraft and it's great.

Thanks very much for your support.

Frank

Link to post
Lefteris Kalamaras

Frank-

We put tremendous emphasis on customer support. There are many examples out there of companies who only care for the before-the-sale part of the deal. We will NOT be one of them, ever.

If there are recurring problems our customers might be facing, then these problems are NOT with the customers - they're with the procedure and we'll do our best to solve them. Happily, at the moment there's only a few "beginner" type issues that have surfaced, that have easily been resolved.

We're very glad to provide service to you and hope you'll be returning to Flight Sim Labs for our next products!

Link to post

Frank,

GFConfig v. 1.77 works just fine for me under Vista 64.

And it would be odd in the extreme for 32-bit software to

be compatible with Vista-64 and not Vista-32.

Just thought you may want to know.

Cheers,

jahman.

Link to post

Jahman,

Well, odd or not GFDevFSX.exe does not operate properly under Vista 32-bit and FSX.? What happens is the GoFlight software loads as you execute FSX.? Shortly after the opening screen for FSX the databridge software and FSX terminates.? This is a known problem and GoFlight is working on a fix - now in BETA.

You can read a number of posts on AVSIM and in the forums on the GoFlight sight.? I do not know how Vista 64-bit handles the databridge interface but obviously there is something different.

Frank

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...