Jump to content

Concorde Performance System: Calculations For Any Route


Ramón Cutanda

Recommended Posts

  • Replies 1.7k
  • Created
  • Last Reply

Top Posters In This Topic

  • Pierre Chassang

    535

  • Ray Proudfoot

    241

  • Ramón Cutanda

    64

  • Steve Prowse

    50

Top Posters In This Topic

Popular Posts

Hello Captains, Please have a lokk here:

Dear Captains, Next Wednesday I will meet an ex-Concorde real life pilot. I will discuss with her of several Concorde X vs real aircraft differences. During development, she already

Concorde Performance System X: http://concordeperformancesystem.org/   Concorde Performance System X (referred to as CPS-X hereafter) is a standalone utility which can be used with SS

Posted Images

Hi Pierre,

Thanks for not forgetting me. I appreciate it a lot! It seems that the problem is still there. This is what it looks like. Google says "Invalid at the highest level in the document" regarding the Swedish part. I assume that it is referring to the first line in the file where it says [FSCFP] - if opened as a text file.

The strange thing is that I close it by clicking "OK" and when I click the "Add route" again, and choose any route, this is what shows:

So, first try, I get the first window, second try to load route, I get the French window above. Every time.

Any ideas?

Best Regards

Link to post

Apparently, the pictures did not show in my message. Second said: Violation d'accès à l'adresse 006EDDAB dans le module 'CPS.EXE'. Lecture de l'adresse 00000000.

Thanks again,

Link to post
Pierre Chassang

Hi Zacharias,

Hey! I found the origin of your issue... !!!

I really don't like lose against my own program!

In fact you are using the wrong file with CPS. The file you're using is a FS Commander plan, not a FS plan.

That's why you see "[FSCFP]" meaning FS Commander Flight plan.

You must export this flight plan to FSX format with FS Commander and every thing should work.

Try, please and tell me...

Thanks

Kind Regards

Link to post
Craig Udseth

Hi Pierre!

Finally got a chance to try a flight but when I tried to use your program (v1.4.2) it would not allow me to continue because there was an update available. So I uninstalled it and installed v1.50. Reworked the file AKL-PPT and THIS TIME I uploaded the file to FSX ConcordeX. (After first loaded FSX and a Concorde at gate 7 AKL). I selected CPS for "load" and CPS for "fuel" in the FSLabs menu tab but I noticed that the CG did not agree with what the program had calculated and the load was not distributed the way I had arranged it in CPS program. I proceeded with preflight, startup, and taxi and attempted takeoff using the trim that was applicable for the displayed CG (I use the virtual FE to perform the engineering duties). When I attempted takeoff it was very nose heavy and hard to control climb. My target CG in CPS was 3.00 (same as your example) and the FE was able to pull it forward only to 52.6 so I set trim to -0.75. In hundreds of flights I have never had issue as long as I trimmed appropriately to the CG present at takeoff.

After analyzing the payload distribution in FSX as well as in the drop-down FSlab tab, it appeared that ConcordeX had its own logic and was simply distributing the load evenly instead of loading it rearward as I had setup in CPS. The result was that instead of ZFW CG of 53.03 as I had programmed it was showing 51.7!

Next I exited FSX, closed everything down and rebooted my computer to clean everything out. BUT when I restarted FSX and tried to access my saved Concorde file the aircraft would not stay stationary but kept dancing and jumping around. I exited FSX and tried again, this time from the default tryke I selected a Concorde livery. Again the aircraft just bounced and danced around very unstable. No matter what I tried I was no longer able to use any Concorde livery plane no matter how I accessed it.

I reinstalled Concorde and everything was back to normal until I tried to use your program again! I wanted to go back to v1.4.2 but you have that interrupt setting that will not allow me to use it. I should have the OPTION of the new version or still use the old current version. The other prompt that endlessly comes up is whether I want to load a previously saved data file ( of which there isn't any) and when I answer "NON" it then comes up with the "...new update" prompt. I cannnot get past these interrupts in order to try using v1.4.2 again.

Apparently something in the "upload to Concorde" process you are using is changing the whole static balance of the aircraft on its wheels(?) I will now have to again uninstall and reinstall ConcordeX in order to make it operational. Unfortunately I will not be able to use your program to upload the data to my plane. I hope you can fix this because though it is possible to use your load diagram as reference to load manually within the FSLabs fuel tab, ConcordeX allows very little payload flexibility.

Link to post

Hi again,

As said before, this is an amazing tool!

Another question; when adding a route I get the message "ADEU file has been created" or something like that, all swell. However, where are they saved?

I tried to specify my FSX folder in the Control Panel Configuration. When I click browse, whatever folder I put there it says "Computer" in the "Flight simulator path". When I check next time, it is empty.

I tried to compy the address to my FSX folder (as in C:\Program files\...\FSX), it doesn't seem to work either.

Main problem would be that the ADEU files are not saved in the FSX/civa/ADEU-folder...

Pierre?

Thanks,

Z

Link to post
Another question; when adding a route I get the message "ADEU file has been created" or something like that, all swell. However, where are they saved?
Main problem would be that the ADEU files are not saved in the FSX/civa/ADEU-folder...

They are saved there.

I tried to specify my FSX folder in the Control Panel Configuration. When I click browse, whatever folder I put there it says "Computer" in the "Flight simulator path". When I check next time, it is empty.

I tried to compy the address to my FSX folder (as in C:\Program files\...\FSX), it doesn't seem to work either.

That's most probably a bug.

If the program is not run as an Administrator, it ignores all these changes made by the user in the config panel.

Run it as Administrator, and it keeps the changes.

Link to post

Morning, I had another thought...

The P7 and the fuel flow bugs are calculated in CPS, and from what I understand, they are just bugs = values to reach before T/O monitor shows green light...

For some trips, values could be 38.5 (P7) and for next trip it could be 40.1 (for example). This means that you demand more thrust on the latter for green light on T/O. Does this mean that there is more thrust? Or more fuel flow?

In such case, where do you do this setting?

Or, is it always the same thrust used?

Eager to know...

Z

Link to post
Pierre Chassang

Hi Zacharias,

P7 and FT calculated by CPS are Max values which must be checked by FE and pilot during Take off.

Green light on each engine just indicates if reheat works well.

During Takeoff the throttles are pushed full forward. Thrust depends temperature, altitude-pressure and some others external factors.

On same WX conditions, thrust will be the same not depending of weight. (But aircraft will need more distance to lift off with more weight).

Hope this help

Cheers

Link to post
Derek Struye

Just installed 1.5.1b, once I load the route, the nautical miles are 0.

Edit: What is the Max Range this program allows? 3860nm is a route I have but this program won't accept it. Is there a way to edit the Max Range?

Manual specs that come with the Concorde X state -->Maximum Permissible Range 4500 miles (3900 nm) btw.

Link to post
Mike Vivaldi

Just installed 1.5.1b, once I load the route, the nautical miles are 0.

Edit: What is the Max Range this program allows? 3860nm is a route I have but this program won't accept it. Is there a way to edit the Max Range?

Manual specs that come with the Concorde X state -->Maximum Permissible Range 4500 miles (3900 nm) btw.

on the reinstall did you delete your old cfg? I had the same issue until I deleted the cfg and reinstalled. It worked fine after that.

Link to post

Hi Pierre,

Ones I got it to work, I use CPS for each flight. Great!

I have a suggestion. Wouldn't it be possible to add "track" (i.e. the direction between two waypoints in degrees) to the route list in the flight log (last page(s)). Since the track can vary during one leg, it would be the average track to be listed (or?). There are quite a lot of pages on the Internet with suggestions on how to program/calculate.

Another thing. This is perhaps too much work? Would it be possible to add DMS/VOR frequencies to the same list? I can see that - when creating a route in FSCommander - this information is shown.

I do not demand or request anything - these are just two suggestions.

All the best to you,

Zacharias

Link to post
Pierre Chassang

True. I find it pretty hard to read the Balance Chart, in french or english; it's rather blurry, maybe due to it seems scaled smaller than it should be. Perhaps flipping it on its side like the Fuel Management Sheet would help.

Hi,

I've looking everywhere on the web to find a solution to Balance sheet blur, but couldn't find one.

The original document is 2339px X 1654px.

The CPS document is 780px X 526px.

It seems impossible to reduce the picture without lose many pixels.

If you know a solution, I will be happy to use it

Cheers

Link to post
Derek Struye

Hi,

I've looking everywhere on the web to find a solution to Balance sheet blur, but couldn't find one.

The original document is 2339px X 1654px.

The CPS document is 780px X 526px.

It seems impossible to reduce the picture without lose many pixels.

If you know a solution, I will be happy to use it

Cheers

Shrinking a bunch is near impossible to maintain sharpness. Only think I can think of is to print the original size on paper and rescan it in a more reasonable size. Depends on how the scanner will handle this.

Edit: This might help too. http://www.sitepoint.com/resize-an-image-in-photoshop/

Link to post

Hi, I have a question.

I'm setting up a flight between TBPB-EGLL - I've set up a load of 65 passengers and generated the route. However it's a little unhappy with the fuel needed. Theres a (Roughly) 100nm subsonic section on the route at the arrival airport and I'd like to have 30 minutes of holding fuel - However with these values it keeps complaining about the amount of fuel being over the maximum. This is a route that I know Concorde used to undertake rather regularly so was wondering if anyone has any tips or ideas where I'm going wrong?

Thanks,

Link to post
Pierre Chassang

Hi,

This Route distance is long flight for Concorde.

Therefore the runway used is 3361m and (during the test I've done) Temp was +25°C and Pressure 1014 mb.

All these parameters reduce the MTOW.

Concerning the amount of fuel, you could cancel the Anti noise departure procedure Increasing the Fuel burn in important proportion.

As the airport is located very near the seashore, This procedure can be cancelled.

All the above can explain why, in certain circumstances, The take off can be prohibited.

Hope this help.

Cheers

Link to post

I'm now getting an error when trying to export the data to Concorde - It gives an error stating; Unable to write to C:\Program Files\Microsoft Games\Flight Simulator X\SSTSIM\Data\Cur_load.ini

It looks like it thinks I've got the FS9 SSTSIM installed for some reason.,.... I'm unable to change the fs9/fs10 settings....

Link to post

Just FYI - I've tried un-installing and deleting the CPS folder, and still no luck. It just won't write anything into that folder. I've even re-installed Concorde X and no joy.

Cheers

Link to post

Hmm strange - Are you flying the same flight plan or have you re-generated the data? When I deleted the converted flight plan and re-imported it this error stopped....

Link to post

And the problem returns! Seems to occur randomly no-matter what I do... Very odd.

Link to post
Pierre Chassang

I'm now getting an error when trying to export the data to Concorde - It gives an error stating; Unable to write to C:\Program Files\Microsoft Games\Flight Simulator X\SSTSIM\Data\Cur_load.ini

It looks like it thinks I've got the FS9 SSTSIM installed for some reason.,.... I'm unable to change the fs9/fs10 settings....

Hi ,

First Sorry for delayed reply, because, I'm just getting out of a bad cold. and was unable to keep the support up to date.

It seems the problem you have has already been discussed on the forum.

When this kind of of trouble occurs, please do not uninstall any thing.

The next 4 principles should in the majority of case be sufficient.:

1- Delete le CPS.cfg.

2- Download the latest version even if you think you already got it.(Because I sometimes add minor modification without changing Version ID).

3- Delete the complete CPS folder installation.

4- Install again CPS. Launch It and create a new CPS.cfg , when settings are completed.

Hope this help

Cheers

Link to post

Hi Pierre,

Thanks for that will give it a go tonight and let you know.

Its odd as it was working fine up until sunday night, then stopped working. Then after a few uninstalls started working agian, and then yesterday stopped again - I think my computer is trying to tell me to go and spend some time outside instead of sitting indoors in a dark room on a computer!!

Link to post
Pierre Chassang

Hi Gents,

The issue encountered by Severniae is as he says himself very odd.

I will accurately looking the reasons why to avoid other users have them.

To Stephan, I need feedback on the freezes at take-off.

Is it CPS freezing on T/O page or FS during take-off.

More you give me detailed informations, more I could help you quickly

Thanks to all

Link to post

Pierre,

Thanks for the reply. Unfortunately I tried your suggestion and it's still not loading the files properly and still gives me the same error message.

Thanks,

Link to post
Pierre Chassang

Dear James,

I would like you send me a detailed and illustrated chronologic path of what you've done to obtain this result.

I'm no afraid by number of pictures which often speak as well as lon text.

Could you do that for me, I'd really like to help you.

Cheers

Link to post

Hi Pierre - No problem. I'm not going to be able to get to my FSX computer until later in the week but as soon as I do I'll get this for you.

Thanks,

James

Link to post
Pierre Chassang

Hi, James

In the meantime, could you by memory make me a summary of your installation (Number of PC, network type if so, what is installed where and so on)

This could gain time to understand your problem.

Thanks a lot

Link to post
Pierre Chassang

Hi Pierre,

Ones I got it to work, I use CPS for each flight. Great!

I have a suggestion. Wouldn't it be possible to add "track" (i.e. the direction between two waypoints in degrees) to the route list in the flight log (last page(s)). Since the track can vary during one leg, it would be the average track to be listed (or?). There are quite a lot of pages on the Internet with suggestions on how to program/calculate.

Another thing. This is perhaps too much work? Would it be possible to add DMS/VOR frequencies to the same list? I can see that - when creating a route in FSCommander - this information is shown.

I do not demand or request anything - these are just two suggestions.

All the best to you,

Zacharias

Hi Zach,

True route for each leg added in next version...

Enjoy!

Link to post
Derek Struye

Any chance you can make this program editable to allow for longer flights? I know it may not be realistic but this is all suppose to be for fun. For example, there are times when I want to try and do a flight I've setup that may end up to be 4200nm, which could be actually possible if the wind is with you and a light load. :) -Derek

Link to post

Hi Pierre,

Im running everything on one PC - fsx directory and CPS on the same drive (C: drive) I only have FSX installed.

I have orbx an a few addon airports, also using Radar contact or Pro ATC/X (not at the same time obviously!)

Thanks,

Link to post

Hi Pierre

Firstly, thank you for taking the time to create this amazing program.

I have updated to the latest version (1.5.4.0b) and have noticed that when i enter the airport ICAO FAJS i get an error "" is not a valid integer value.

could FAJS be missing from the database?

thanks again for this program

sean

Link to post
Pierre Chassang

Hi Sean,

The ICAO code FAJS no longer exists.

"On 10 January 2013 the airport's ICAO code was changed from FAJS to FAOR." (Wikipedia)

Cheers

Link to post

×
×
  • Create New...