Jump to content

Weird Autopilot movement when approaching Localizer


Luu Phu Lam

Recommended Posts

Luu Phu Lam

Hi

I'm having a bit annoying problem with the autopilot. Sometimes when the aircraft is approaching to the localizer, as soon as I press LOC or APP button, the aircraft acts weird and banks to the opposite direction and flies away from the Localizer. Sometimes it even overbanked then the autopilot disconnected itself. It only happens sometimes when I activate the LOC or APP mode on the ILS approach. I tried another aircrafts from PMDG and they work fine. The approach angle to the Localizer is from 20-45 degree only. Could anyone advise!!!

Many thanks,

LAM.

Link to comment
Stu Antonio

Does this happen at every airport?

Is your AIRAC up to date? (discrepancies can lead to strange behavior)

You write "as soon as I press .... ", so it doesn't matter how far away you are from the localizer? It really does that the moment you press APPR on the FCU?

 

 

 

Link to comment
Luu Phu Lam

Hi Soren,

I normally don’t arm the approach mode manually in fmc since I thought the aircraft will arm itself when passing by the Final Approach point. There were few times I didn’t follow the flightpath till the end and did the vector to final before the aircraft reached Final Approach Point. Maybe that’s what caused the problem? 

2 hours ago, Søren Rasmussen said:

Which airport? And did you arm approach mode in the MCDU (guess you did, but just to know)?

 

 

Link to comment
Luu Phu Lam
1 hour ago, Stu Antonio said:

Does this happen at every airport?

Is your AIRAC up to date? (discrepancies can lead to strange behavior)

You write "as soon as I press .... ", so it doesn't matter how far away you are from the localizer? It really does that the moment you press APPR on the FCU?

 

 

 

hi Stu no it just happened a few times and not with all airports. Maybe because I did the vector to final and forgot to arm the APP mode manually. I will make a flight and let’s see if it’s the issue. Thanks!

Link to comment
  • 1 month later...
Luu Phu Lam

Hi,

I made few flights again and the issue still happened. You can see the my attached picture. Even the aircraft is locked to Localizer and G/S but somehow the F/D commands the aircraft to turn to opposite direction. If I keep the A/P on, the aircraft will swing left and right to the Localizer. This happened at WMKK airport but I tried with other PMDG aircraft and they worked perfectly. With other airports sometimes the issue happened too even I activated APP mode in the FMGS before arming the APP, the aircraft sometimes makes a weird turn before correcting itself to catch up with the LOC. And it only happened to Fslabs aircrafts. 

Could someone please advise???

LAM. 

Untitled.png

Link to comment
Luu Phu Lam
21 minutes ago, Daniel Harms said:

I‘ve exactly the same problem during various approaches

Thanks for your reply. It seems like a bug of the product. Hope the dev is finding the way to fix it. It's so annoying.

 

Link to comment
Riccardo Masia

Have the same problem. I believe the reason is that the aircraft actually mirrors the fly-left/right direction it gets from the localiser, as if it captures some kind of false course.

Link to comment
  • 3 weeks later...
Andre Da S Marinho

Are you sure you have the loc or g/l alive when you arm the approach mode ? Something important to check is that you are tuned on the right frequency, curse and identifier.  cross checking with the charts. It happened to me when I was far more than 27nm dme. wich is normal.  so for now on I only arm the app when I am less then 25nm and I am sure to be tuned to the right frequency, ID and curse. You see it on the PFD left down corner (magenta) at the same time you see its alive.

Link to comment
×
×
  • Create New...