Jump to content

GSX Update 2.9.4+ | Unusual/wrong boarding process


Stu Antonio

Recommended Posts

Stu Antonio
1 hour ago, Andrew Wilson said:

@Stu AntonioHave it go wrong, and then upload your ATSU.log for me? Unless you still have your log from yesterday.

Okay, I did the same as yesterday with the above OFP, see my ATSU.log attached. I also recorded my procedure (with instant fuel load but that doesn't matter, it's the same with GSX refuel) in a 9min video below with flight crew and mini van arriving. As mentioned, this happens every time since the update.

ATSU.log

 

Link to comment
virtualisoftware

I'm very sorry guys, but I found the problem and, this time it was MY FAULT.

I was trying to Debug the issues using the Debug version of GSX, so I could manually set the variables, and that worked fine, so I couldn't explain why it happened to you so, after hours and hours of debug, and checking, and going through every line of code in the Addon Manager, Couatl, GSX, step by step, I finally found the cause:

I must inadvertently removed ONE LINE of code in the RELEASE (only) version of GSX and this one was exactly the one that resets all GSX variables to 0 when GSX starts!

The line was still there in the Debug version, which is what I had to use to troubleshoot the problem, and that was what mislead me thinking it was all fine, because it was, in Debug mode...

Without that initial reset, all those variables were unknown to the sim, until something else wrote to them, which could have been either the airplane code, but also my tests made using the command line, which further mislead me it was working correctly because, while testing, I "woke up" the variables which were otherwise not initialized.

The fix is of course already online now in the FSDT Live Updater, and I apologize again for all the troubles caused. I'm sure this will fix any similar issue of problems with GSX airplane integration.

  • Like 4
  • Thanks 14
  • Haha 1
Link to comment
Stu Antonio
23 minutes ago, virtualisoftware said:

I'm very sorry guys, but I found the problem and, this time it was MY FAULT.

I was trying to Debug the issues using the Debug version of GSX, so I could manually set the variables, and that worked fine, so I couldn't explain why it happened to you so, after hours and hours of debug, and checking, and going through every line of code in the Addon Manager, Couatl, GSX, step by step, I finally found the cause:

I must inadvertently removed ONE LINE of code in the RELEASE (only) version of GSX and this one was exactly the one that resets all GSX variables to 0 when GSX starts!

The line was still there in the Debug version, which is what I had to use to troubleshoot the problem, and that was what mislead me thinking it was all fine, because it was, in Debug mode...

Without that initial reset, all those variables were unknown to the sim, until something else wrote to them, which could have been either the airplane code, but also my tests made using the command line, which further mislead me it was working correctly because, while testing, I "woke up" the variables which were otherwise not initialized.

The fix is of course already online now in the FSDT Live Updater, and I apologize again for all the troubles caused. I'm sure this will fix any similar issue of problems with GSX airplane integration.

I can confirm, it has been fixed! :)

No flight crew, no mini van. All works like it should now. Awesome.

Thanks!

Link to comment
Bernhard Scharbert

Ok Umberto, everything works now as it should be. Such a tiny thing can oneself drive crazy if just 1 little line amongst hundreds/thounds of lines was faulty. Thanks for your apologies. Good to see that THIS TIME it was not our user fault :rolleyes:;)

Bernhard

  • Haha 1
Link to comment
Sunny Andonov

I am actually having this problem that when I call GSX for boarding instead of conveyor belt I am getting the cargo loaders. This happened after the GSX update. Is it just me or someone else also sees this?

Link to comment
John Ruisch
On 9/24/2021 at 10:23 PM, Sunny Andonov said:

I am actually having this problem that when I call GSX for boarding instead of conveyor belt I am getting the cargo loaders.

You have to change this in your fltsim.cfg 

[Options]
cargo_belts=1

Link to comment
Sunny Andonov
17 hours ago, John Ruisch said:

You have to change this in your fltsim.cfg 

[Options]
cargo_belts=1

Thanks for your answer. I wonder, is this something new? I don't remember ever doing that. 

Link to comment
Koen Meier
12 minutes ago, Sunny Andonov said:

Thanks for your answer. I wonder, is this something new? I don't remember ever doing that. 

the cargo belts option has been there since the beginning of the interaction.

Link to comment
×
×
  • Create New...