Jump to content

P3D v. 5.2 is out


Søren Rasmussen

Recommended Posts

  • Replies 150
  • Created
  • Last Reply

Top Posters In This Topic

  • Norman Blackburn

    13

  • Stu Antonio

    12

  • Koen Meier

    9

  • Danny Moore

    8

Top Posters In This Topic

Popular Posts

Hi, we have not run into any major issues, but as is usual after a P3D update release, we are giving our beta testers a few cycles before we release, just so we ensure we don't run into any snags

We have a version in testing from last night.  Its a case of us needing to check things out.

Waiting for people posting why FSL won’t start after instantly jumping on 5.2 .....     

Posted Images

Andrew Wilson
Just now, davide montana said:

to provent licence error is better now to keep it installed on p3d v5.2 or unistalled and then, when available, use install the new version?

If you've switched to v5.2 you can uninstall the A320-X for now, and install again once we release the compatibility update for P3D v5.2.

Link to post
Norman Blackburn
1 minute ago, davide montana said:

oh no, i have installed the new '3d v5.2 becuse i see bb on live and i was thinking was out also for us

let's wait...now i will not use the fslab in this case :D 

 

You could roll back to 5.1 if you wished.  Grab just the client from P3D downloads.

Link to post
davide montana
3 minutes ago, Norman Blackburn said:

You could roll back to 5.1 if you wished.  Grab just the client from P3D downloads.

yes, maybe is the best option to avoid too much waiting time :D

but anyway not a big drama, take the time that you team need to test it :D 

if i unistalled now and istalled again on p3d v1 i should not get the licence error?

Link to post
Norman Blackburn
Just now, davide montana said:

yes, maybe is the best option to avoid too much waiting time :D

but anyway not a big drama, take the time that you team need to test it :D 

if i unistalled now and istalled again on p3d v1 i should not get the licence error?

When uninstalling 5.2 it will ask if you want to deactivate your license.  Either answer works but no is the correct one.

 

Link to post
davide montana
3 minutes ago, Norman Blackburn said:

When uninstalling 5.2 it will ask if you want to deactivate your license.  Either answer works but no is the correct one.

 

thanks! and for the fslab i need to unistalled it before unistalling the simulator? to avoid also there problem  with the licence?

 

Link to post
Norman Blackburn
1 minute ago, davide montana said:

thanks! and for the fslab i need to unistalled it before unistalling the simulator? to avoid also there problem  with the licence?

 

It shouldnt care.

Link to post
Koen Meier
3 minutes ago, Yang Shuo said:

do not update to 5.2 , It have some big bug of EA Volumetric clouds

I feel for everyone this is a decision they have to make for themselves. additionally i feel that a complete reinstall of the sim with such a big update can prevent issues.

also clouds are able to block terrain from being visible.

Edited by Koen Meier
  • Like 2
Link to post
Norman Blackburn
2 minutes ago, Yang Shuo said:

do not update to 5.2 , It have some big bug of EA Volumetric clouds

The better advice is "Do not use Volumetric Clouds"  

 

  • Like 3
  • Haha 2
Link to post
Ivan Majetic

I nuked everything this morning, and starting from scratch, had at times so much stuttering that it was unflyable. Either clean reinstall didn't do it's thing or some addon was causing it. 

Link to post
Koen Meier
1 minute ago, Ivan Majetic said:

I nuked everything this morning, and starting from scratch, had at times so much stuttering that it was unflyable. Either clean reinstall didn't do it's thing or some addon was causing it. 

sometimes you have to make the decision to a full scratch reinstall of the OS too. not the most enjoyable decision to make but sometimes it has to happen.

Link to post
Ivan Majetic
22 minutes ago, Koen Meier said:

sometimes you have to make the decision to a full scratch reinstall of the OS too. not the most enjoyable decision to make but sometimes it has to happen.

Exactly, I agree.

Link to post
Koen Meier
2 minutes ago, Matthew Miller said:

THANKS.. Just dont understand why P3D wont let you install v5.0 anymore... 

LM only allow clients to be downloaded but do not store whole versions. so best is to keep a previous version full download somewhere.

Link to post
Matthew Miller
Just now, Koen Meier said:

LM only allow clients to be downloaded but do not store whole versions. so best is to keep a previous version full download somewhere.

yeah i didnt know all that when I rebooted my PC and came back to p3d downloads and its only 5.2........ So literally stuck with a fresh PC but cant fly the fslab or pmdg..... 

Link to post
Matthew Miller
4 minutes ago, Koen Meier said:

LM only allow clients to be downloaded but do not store whole versions. so best is to keep a previous version full download somewhere.

 

Just now, Koen Meier said:

pmdg isnt version locked unlike fslabs. so you can try to install it and see what happens but it is unsupport i believe stiill.

yeah its says v4 and v5 not gonna risk it yet.... just hoping fslab gets 5.2 soon and not weeks or months... I mean if I bought a brand new 4k PC today I wouldnt be able to us fslabs??????? its the only reason I use p3d lol

Link to post
Stu Antonio
1 hour ago, Matthew Miller said:

I mean if I bought a brand new 4k PC today I wouldnt be able to us fslabs


Give them a couple of days, they are just making sure everything works correctly. Those compatibility updates usually don’t take weeks.... 

Link to post
Matthew Miller
7 minutes ago, Stu Antonio said:


Give them a couple of days, they are just making sure everything works correctly. Those compatibility updates usually don’t take weeks.... 

fingers crossed 

  • Like 1
Link to post
Joakim Ewenson
1 hour ago, Matthew Miller said:

yeah i didnt know all that when I rebooted my PC and came back to p3d downloads and its only 5.2........ So literally stuck with a fresh PC but cant fly the fslab or pmdg..... 

The PMDG 737NGXu and 772/773 works just fine in P3Dv5.2, I’ve tried flights with both without any issues.

Link to post
Mateusz Chalupniczak
2 hours ago, Koen Meier said:

pmdg isnt version locked unlike fslabs. so you can try to install it and see what happens but it is unsupport i believe stiill.

Hope links are not forbidden.

https://forum.pmdg.com/forum/main-forum/pmdg-737-ngxu-for-prepar3d-v4/129064-loss-of-fps-on-p3d-5-2?p=129100#post129100

 

There is no real reason to bind aircraft to specific version. And if there is then please advise because I'm very curious.

  • Like 1
Link to post
Norman Blackburn
24 minutes ago, Mateusz Chalupniczak said:

There is no real reason to bind aircraft to specific version. And if there is then please advise coz I'm very curious.

Thanks Matuesz, 

Unlike some others we work  outside of the SDK in providing elements which in turn require very specific elements of P3D which may change from one build to the next.

  • Thanks 1
Link to post
Danny Moore

Give them a couple of days, they are just making sure everything works correctly. Those compatibility updates usually don’t take weeks.... 

I’m sure the update will be out SOON! LOL

On a side note, seeing it’s Friday I don’t expect to see an update until sometime next week at the earliest.


Sent from my iPhone using Tapatalk
Link to post
Timm Rehberg
1 hour ago, Marvin Toepfer said:

see frames and vram above - active sky, ORBX global, europe, germany north...taken in hamburg. EA without volumetric clouds

Remove 35 FPS and add 4GB of VRAM with using FSL :D 

Link to post
Marvin Toepfer
24 minutes ago, Alexander Polcher said:

I mean, thats the stock F35, isn't it? Is there a real advantage against 5.1 after all?

yes, its the p3d f35.
i never had such a good performance, no stutters at all and great fps (which i have locked now)
night lighting is very well done, vram management as well (even if i wasnt affected of that)
EA with legacy clouds is lovely

Link to post
Miguel de gonzalo
1 hour ago, Marvin Toepfer said:

ver fotogramas y vram arriba: cielo activo, ORBX global, europa, alemania norte ... tomada en hamburgo. EA sin nubes volumétricas

Any improve on fps performance ? I know they improved on vram usage 

Link to post
Marvin Toepfer
16 minutes ago, Miguel de gonzalo said:

Any improve on fps performance ? I know they improved on vram usage 

no stutters, great fps (see screenshot). 

Link to post
Norman Blackburn
25 minutes ago, Timm Rehberg said:

Remove 35 FPS and add 4GB of VRAM with using FSL :D 

if by 4GB you mean 0.9GB then yes.

  • Confused 1
Link to post
Miguel de gonzalo
54 minutes ago, Marvin Toepfer said:

no stutters, great fps (see screenshot). 

Yes , but same fps as 5.1 or any improvements ? Thanks for your answer , very good news there is no stutters , 

Do you have latest windows updates on it ? Also those kb5xxxxx ? 

Link to post
Marvin Toepfer
5 minutes ago, Miguel de gonzalo said:

Yes , but same fps as 5.1 or any improvements ? Thanks for your answer , very good news there is no stutters , 

Do you have latest windows updates on it ? Also those kb5xxxxx ? 

yes, I installed all win updates before and checked in bios afterwards that hyperthreading is disabled (that gave me stutters even with good frames).
5.1 was ok but I never had such a good performance (also not with those p3d planes...)
but at the end it's a matter of your settings and computer as always. 

  • Like 1
  • Thanks 1
Link to post

×
×
  • Create New...