Jump to content

DXGI_ERROR_DEVICE_HUNG P3D 5.1


Rene Schlischka

Recommended Posts

Rene Schlischka

Hello, does anyone know if this is a bug known to LM ? All FlightSim forums are full , but at LM Forum I can not find any official statement about it.

All proposed aids do not bring reliable success

All known solutions like:

- Registry entry

- TFDI reallight and tureglass.dll to off

- Change settings

- other driver version

All these things have no success with me, the error appears every now and then.

Link to post
Gregory Verba

Hi Rene, 

Are you using latest gpu driver? Any settings in Nvidia control panel / Nvidia inspector?

Are you windows 10 is up do date (v2004)?

Link to post
Rene Schlischka
2 minutes ago, Gregory Verba said:

Hi Rene, 

Are you using latest gpu driver? Any settings in Nvidia control panel / Nvidia inspector?

Are you windows 10 is up do date (v2004)?

latest gpu driver AMD for 6900xt and Win 10 2004H2 latest version with all updates

 

Link to post
Erik Schlijper

Hey Rene,

I've had this issue alot!
What fixed it for me was to clear the DirectX Shaders Cache. To do so, head into your Settings (right click start-menu then left on settings). Up next you go to System, then on the left you select Storage.  There will be a line saying Temporary Files, click that and let it index. Once that is finished you check DirectX Shaders Cache. Then you click Remove Files button on top and the Cache has been cleared.

I dont know if it will fix your problems just my 2 cents from what helped me.

  • Like 2
Link to post
Rene Schlischka
34 minutes ago, Erik Schlijper said:

Hey Rene,

I've had this issue alot!
What fixed it for me was to clear the DirectX Shaders Cache. To do so, head into your Settings (right click start-menu then left on settings). Up next you go to System, then on the left you select Storage.  There will be a line saying Temporary Files, click that and let it index. Once that is finished you check DirectX Shaders Cache. Then you click Remove Files button on top and the Cache has been cleared.

I dont know if it will fix your problems just my 2 cents from what helped me.

Thanks I will try, let's hope for the best.

I have never had this problem before, except for the graphics card and therefore the drivers I have not changed anything. But since the problem also occurs with Nvidia cards, I suspect it is not a general AMD problem.

Link to post
Marc Ehnle
48 minutes ago, Rene Schlischka said:

Thanks I will try, let's hope for the best.

I have never had this problem before, except for the graphics card and therefore the drivers I have not changed anything. But since the problem also occurs with Nvidia cards, I suspect it is not a general AMD problem.

If you have got a new graphics card you definitely need to get rid of the mentioned cache files. Also make sure you delete the shader folder of P3D (appdata, roaming, LM). These files will get replaced after some time but some older files remain always. It‘s also wise to delete the P3D.cfg and let it rebuild to get rid of your old card in P3D.

Link to post
Walter Meier

Another thing you might want to look at is whether you have a gaming type graphics card that comes overclocked out of the box. I have one of those, and since I toned down the overclock, I haven't seen this crash again.

  • Like 1
Link to post
Sebastian Brabsche

I have also had this par times, mostly at the airport at night.
I got this link from another forum as a tip, maybe you try it.
I've done it recently but no experience so far.

  • Like 1
Link to post
Ross McDonagh
On 2/1/2021 at 6:56 AM, Erik Schlijper said:

Hey Rene,

I've had this issue alot!
What fixed it for me was to clear the DirectX Shaders Cache. To do so, head into your Settings (right click start-menu then left on settings). Up next you go to System, then on the left you select Storage.  There will be a line saying Temporary Files, click that and let it index. Once that is finished you check DirectX Shaders Cache. Then you click Remove Files button on top and the Cache has been cleared.

I dont know if it will fix your problems just my 2 cents from what helped me.

Erik & Rene,

 

I had the DXGI issue at dawn/dusk/night/in weather when I first started... 

I tried: 

 

-Reg edit thing TDR delay: no joy 

-Tweaking settings 

-Turning TrueGlass off (it’s supposed to be fixed now but I’ve kept it off-but it still kills my MD80 when it’s on) 

What FINALLY actually WORKED for me I found in an old Avsim thread and gave it a try: 

Using MSI Afterburner, I limited the GPU power limit from 100% to 97-98% and it literally solved every DXGI hang issue at dawn/dusk/night/in weather in the FSL and a few expensive Boeing’s I fly from time to time...

I never knew about the DirectX shaders cache-only the P3D shaders cache...  

Do you think it could be worth a try to clear my DX cache and attempt to turn the GPU power limit back up?  
 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...