Jump to content

Brakes not slowing the aircraft down fast enough.


Michael Jones

Recommended Posts

Michael Jones

Hello all,

I recently started flying the Concorde again after about 2 years. I have the P3D version (1.41) installed and have only one problem. Since there is no longer official support I am requesting your help. The problem is the brakes will not slow down the aircraft fast enough. Everything is set up properly, such as the sensitivity(full right)/null(full left) and the brake axes with reverse ticked. As a test I start on a runway and load the ready for takeoff scenario.  I checked that there are no warnings, the blue and green hydraulics are on and the ground hydraulics is set to yellow/yellow, off and off. I set the parking brakes to off, note that the P3D brake light disappears, advance the throttle (no reheats) until a speed of 40 kts. is reached . I then press the brakes, note that the brake pressure monitor needles move up to the 13/13 position, the brake pressure dial on the FE panel shows a pressure reading of 2.6 psi, the anti-skid lights on and blinking and the P3D brakes notice show. The ground speed however only very slowly moves down.

I have tested my Saltek pro flight rudder pedals with the other aircrafts installed in P3D v3 and it slows them down very quickly. The problem only exists with the Concorde.  

I have Windows 10 pro (up to date) with the the latest Nvidia drivers (same problem with the  old drivers recommended).

 

Michael A. Jones

 

Link to post
Konstantin

How fast are the brakes slowing down the aircraft (how many knots per second)?  Keep in mind that most default P3D/FSX airplanes have brakes that are unrealistically strong, so Concorde-X models the brakes actually pretty well. Do you also use reverse thrust after landing?

Link to post
Michael Jones

It slows at about 1 knot per second. I tested using Level D 763. Reverse thrust works fine after landing. Idle at 50 knots and brakes applied. I am force to shut down Engine 2 & 3 to help with the slowing since the brakes are not slowing the aircraft fast enough.

 

Link to post
Konstantin

1 knot per second is indeed too slow. Can you try to press the . button when you brake the next time to find out if it's a problem with Concorde-X or with the controller?  

Link to post
Michael Jones

Tried . key. No effect. Pedals are properly calibrated both in P3D and FSUIPC. Keep in mind that Concorde’s instruments show pressure being applied. It is just not reaching the wheels.

Link to post
Konstantin

In that case, I am currently out of ideas. Hopefully someone from the developers will chime in and help you. I hope it happens soon.

Link to post
Ray Proudfoot

@Michael Jones, how much fuel is loaded when you brake? If the tanks are near full that’s a lot of mass to slow down.

How are landings? With around 15T or less it should slow much quicker. Once the nose-wheel touches down full reverse thrust plus manual braking should bring her to a halt in a reasonable distance.

Link to post
Michael Jones

On my last flight I landed with 8 tons fuel which I know was dangerously low.  Brakes was still not working as they should and I almost ran out of runway.

Link to post
Ray Proudfoot

This is baffling. How about an uninstall and reinstall?

Link to post
Ray Proudfoot
19 hours ago, Michael Jones said:

Tried . key. No effect. Pedals are properly calibrated both in P3D and FSUIPC. Keep in mind that Concorde’s instruments show pressure being applied. It is just not reaching the wheels.

Have you disabled controllers in P3D if you’re using FSUIPC for assignment and calibration?

Link to post
Fraser Gale

Just as a test, what happens if you land then apply the parking brake?  If you still don't slow like hitting a wall there is something very wrong - this was an emergency procedure anyway! 

With maximum reverse and maximum brakes (not used on long runways) you could stop her in quite a bit less than 4000ft of runway at light weight.  

Link to post
Norman Blackburn

You should try this:

Uninstall.

Delete the Concorde folder in its entirety.

Reinstall.

Link to post
Michael Jones

I did that. Deleted FSLabs folder in P3D as well as the Concorde folder under SimObjects. Also removed entries in the dll.xml file before reinstalling after restarting the computer. I had redownloaded the installation file in case the one I had was corrupted.

Link to post
Ray Proudfoot

Where is P3D installed? Not inside Program Files(x86) I trust. Mine is in D:\P3Dv3.

Are you launching P3D with admin privileges? Straw clutching mode! :D

Link to post
Andrew Wilson
3 hours ago, Michael Jones said:

Used F1 to idle engine, F2 (one press) after reverse ended, used parking brakes, shift + P no effect although the last one had an effect when taxing at 11 knots.

What are you pressing Shift+P for? Isn't that assigned to push back? My suspicion would be something conflicting there.

Link to post
Michael Jones

I used Shift+P to help in slowing the aircraft when taxing in addition to the brakes. Once it slowed to the speed I wanted or came to a stop it was used again to cancel the push back. It was not used in the video I uploaded.

Link to post
Fraser Gale

Having watched your video, it looks like a bizarre set of events.   I noticed the brake accumulator pressure was consistently lower than 4000psi which is the nominal and I would expect that to increase after the initial application from the main hydraulic supply.  It maybe does this all the time thought as I'm never looking at it on landing!

It's like your simulator brake control isn't working rather than the Concorde's one.  Other than that, no clue!

Link to post
Michael Jones

For the third time I performed a uninstall/reinstall but this time following step by step the procedure set out by Kyprianos Biris

Unfortunately the problem remains. I have done everything I can think of and will now uninstall the aircraft and wait for the new Concorde. Hopefully it won’t be too much of a long wait.

Link to post
Fraser Gale

Do you have other addon aircraft installed other than FSLabs?  Only thing I can think of is one of them messing with your brakes...

Link to post
×
×
  • Create New...