Jump to content
Alex Ridge

P3D V5 - External view performance

Recommended Posts

Alex Ridge
33 minutes ago, Alex Ridge said:

Thanks for making this a sticky and redirecting the thread Lefteris.

 

Like many , i will try the mipmap option, but in the past this has made the displays blurry.

 

Will report back. 

 

Reporting back. Turning OFF VC mipmap.

 

Significantly noticeable increase in performance, especially in the external view.

 

I am happy to continue doing this for now, even though the displays do not look as good, but why does this happen Lefteris? Is it yet another Lockheed Martin bug, or something you guys are looking into?

 

Alex 

Share this post


Link to post
Lefteris Kalamaras
1 minute ago, Alex Ridge said:

...why does this happen Lefteris? Is it yet another Lockheed Martin bug...

I am flattered you ask me as if I know all :D. In this case, I am not sure, tbh. Perhaps a question in the LM forums?

Share this post


Link to post
Charlie Cobb
16 minutes ago, Alex Ridge said:

 

Is it yet another Lockheed Martin bug, or something you guys are looking into?

i dont have this bug with any other aircraft in v5, never had to touch the mipmap setting before

Share this post


Link to post
Alex Ridge
18 minutes ago, Lefteris Kalamaras said:

I am flattered you ask me as if I know all :D. In this case, I am not sure, tbh. Perhaps a question in the LM forums?

Well then it is probably something your end. :D

Share this post


Link to post
Danny Moore
Im surprised so many people have mip maps on. They caused stutters in v4 and in both versions they make cockpit displays more blurry.

Using v4 with MM on and my displays are clear and crisp with no stutters. Maybe on your system it’s a problem but for many others it works perfectly fine.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Michael Petersen
4 hours ago, Will Tearne said:

I'm just staying in the cockpit for the whole flight because the outside view performance is just not good at all. In P3D v4.5 I never had this issue with the A321 when they implemented the PBR for it, so it's either something to do with P3D v5, or something to do with the PBR implementation in the A320. One thing I have noticed is that without Mipmaps, the flight information does not stay current on the instruments when in outside views. Having Mipmaps on, the flight information does stay current when in outside views. Just an observation that I had so it might have something to do with it.

I Also see some weird stuff going frome external to VC on the instruments.

Also throttle to toga after touchdown in external view.Maybe Chaseplane issues?

Also ASP3D at EDDH was hefty today and i had really struggle with weather and some serious frightened sounds in cockpit like the plane is falling apart.

Michael Moe

Share this post


Link to post
brendon powys

Anyone who's getting jagged display text with MM disabled, try AA  4xSSAA setting. It worked for me and still very smooth 

Share this post


Link to post
Alexander Sigg
1 hour ago, brendon powys said:

Anyone who's getting jagged display text with MM disabled, try AA  4xSSAA setting. It worked for me and still very smooth 

4xSSAA and Even 8xSSAA at day light on my 1080ti is no issue but as soon some dynamic lighting gets in to play it’s no option for me . I could switch as soon it’s get dark. But I don’t want to fly with being in the menu every 15 min. 

Share this post


Link to post
Roar Kverneng

I have a drop to about 20 FPS in P3dv4 external view....

  • Like 1

Share this post


Link to post
Alexander Petrenko
20 minutes ago, Roar Kverneng said:

I have a drop to about 20 FPS in P3dv4 external view....

I would kindly suggest moderators to split messages from this topic into 2x different topics - P3Dv5HF2 and P3Dv4.5HF3.

Obviously FPS drop issue on external views appears to be relevant for both versions.

Share this post


Link to post
Roar Kverneng
1 minute ago, Alexander Petrenko said:

I would suggest moderators to split messages from this topic into 2x different topics - P3Dv5HF2 and P3Dv4.5HF3.

Obviously FPS drop issue on external views appears to be relevant for both versions.

Thats correct!

Share this post


Link to post
James Harker

It does seem to be the case on both versions, I run P3Dv4HF2.

My frames spike from a normal stable (locked) 30 down to around 20 with the A320 now from push & start until I reach the higher levels above say FL200+, where they return back to normal.  I get the reduced performance in the external and VC view.

The A321 still appears to be fine in my limited testing so far, as it has been ever since I've owned it, so PBR cannot be the sole reason surely?  There must be something going on with the A320 causing this with the latest update.

 

Share this post


Link to post
Harald Huber

On P3d V5 HF2, disabling Mip Mapping gives a huge FPS boost, if the A320 was enjoyable before, now it's like I am dreaming, runs amazingly!! 

2020-7-1_19-38-32-681.png

  • Like 1

Share this post


Link to post
Alexander Sigg

Hi guys,

so I did spend the last couple of hours trying out different settings regarding this issue and I came to a conclusion. But first here is what I tried:

Its obvious that turning off mipmap VC in the main menu restores the outside fps back to normal. For me the FPS in the VC stay the same. So far so good you would say, right ?

Well not really. For me personally the VC without the mip mapping is just horrible as shown in a comparison above by me. The shimmering and flickering of the numbers and lines are just not pleasant and hard to watch not even speaking of the effect that the data are less readable than with the mipmapping. Therefore, I can not understand Lefteris point saying Mipmap is unnecessary and makes it even less readable?! I can't say how it looks with a 4K Screen or something in this direction. But I can speak for my normal 1080p resolution and my semi-normal (by now:P) 1080ti.

From here on I thought of two ways to find a solution.

First I tried a different Antialiasing mode to smoothing the edges. So I tried 4xSSAA in the main p3d menu. And guess what? It looks good! Looks even better than 8xMSAA with Mipmap. And the FPS on the outside are about 60FPS (which is due to my Vsync) compared to my 25-30 FPS with 8xMSAA and Mipmap. So you would think it's a good solution for a system like mine with 1080ti. Well I thought so too just to get a bummer shortly after. Going in to any dynamic lighting with the bus makes the FPS drop so badly (15-25 FPS). Not only inside but also on the outside. But this story isn't new. It's been always an issue to get SSAA and dynamic lighting working  together.

Secondly I tried to find an external way to Mipmap the VC panels to maybe trick P3D. But for now I could not find a way. And I also don't think there will be.

So here we/I are. A bit stuck.

I do not know why the bus is doing such thing because I have never seen something quite like it.

I really hope the devs can have a closer look on it because for the average user it's just not pleasant to remain like this. If you have any question regarding this just message me! 

So guys, I hope I could save you some hours of testing and I look forward hearing back from the developers.

Cheers! :rolleyes:

  • Like 3

Share this post


Link to post
Charlie Cobb
13 hours ago, Alexander Sigg said:

Hi guys,

so I did spend the last couple of hours trying out different settings regarding this issue and I came to a conclusion. But first here is what I tried:

Its obvious that turning off mipmap VC in the main menu restores the outside fps back to normal. For me the FPS in the VC stay the same. So far so good you would say, right ?

Well not really. For me personally the VC without the mip mapping is just horrible as shown in a comparison above by me. The shimmering and flickering of the numbers and lines are just not pleasant and hard to watch not even speaking of the effect that the data are less readable than with the mipmapping. Therefore, I can not understand Lefteris point saying Mipmap is unnecessary and makes it even less readable?! I can't say how it looks with a 4K Screen or something in this direction. But I can speak for my normal 1080p resolution and my semi-normal (by now:P) 1080ti.

From here on I thought of two ways to find a solution.

First I tried a different Antialiasing mode to smoothing the edges. So I tried 4xSSAA in the main p3d menu. And guess what? It looks good! Looks even better than 8xMSAA with Mipmap. And the FPS on the outside are about 60FPS (which is due to my Vsync) compared to my 25-30 FPS with 8xMSAA and Mipmap. So you would think it's a good solution for a system like mine with 1080ti. Well I thought so too just to get a bummer shortly after. Going in to any dynamic lighting with the bus makes the FPS drop so badly (15-25 FPS). Not only inside but also on the outside. But this story isn't new. It's been always an issue to get SSAA and dynamic lighting working  together.

Secondly I tried to find an external way to Mipmap the VC panels to maybe trick P3D. But for now I could not find a way. And I also don't think there will be.

So here we/I are. A bit stuck.

I do not know why the bus is doing such thing because I have never seen something quite like it.

I really hope the devs can have a closer look on it because for the average user it's just not pleasant to remain like this. If you have any question regarding this just message me! 

So guys, I hope I could save you some hours of testing and I look forward hearing back from the developers.

Cheers! :rolleyes:

I have exactly the same issue, no mipmappinng and 4xSSAA looks good, but at night as soon as my landing lights hit the runway, or any dynamic lights are present, I get huge FPS hit both inside and out. It seems to be a very strange problem.

  • Like 1

Share this post


Link to post
Alexander Sigg
8 hours ago, Sean Green said:

Go to Displays (or visuals cant remember)  under options in the FSLABS MCDU and change VC  to 30 (its initally set on 20)  and see if that helps.  It fixed my stuttering issue inside the VC.  I go to external with just the S key not chaseplane so I did not  see any issues with external views on my setup.

I can´t imagene that increasing the VC Displays FPS will do anything good for the frames in and outisde. In fact I just tested and can´t find a positive difference. 

Share this post


Link to post
Eric Fisher

Well, I installed the latest version and must say I am getting better performance in both VC and external over a certain Boeing product that was just updated and released for v5. In fact it is about 9 to 10 frames better. So much so that as I type this I am 3 hour from landing in said Boeing whereupon I will be flying FSL exclusively from here on out. Now I just need to save for my TH stick so I can put the yoke away!

Share this post


Link to post
Michael O'Halloran
3 hours ago, Eric Fisher said:

Well, I installed the latest version and must say I am getting better performance in both VC and external over a certain Boeing product that was just updated and released for v5. In fact it is about 9 to 10 frames better. So much so that as I type this I am 3 hour from landing in said Boeing whereupon I will be flying FSL exclusively from here on out. Now I just need to save for my TH stick so I can put the yoke away!

What specs do you have? And it seems more on V4 are having the issue. 

Share this post


Link to post
Eric Fisher
15 hours ago, Michael O'Halloran said:

What specs do you have? And it seems more on V4 are having the issue. 

I am on v4.5HF2. I have a 9900k, 1080Ti running at x4 MSAA on a 4k 50in screen. Most all of my sliders are to the right. NVIDIA driver version 445.87.

Share this post


Link to post
Marvin Toepfer

I‘m running v5 on a i7 8770k, GTX1080, 16GB RAM. Mip maps off, no vsync, no FPS limiter. 4SSAA. No triple buffering. No HT.

I get smooth frames inside and outside, textures are crisp. Check in your Nvidia settings your power management mode as well as in windows. 
I don’t run a 4K Monitor and for me those settings are the best. 
 

 

Share this post


Link to post
Lawrence Ashworth
On 7/3/2020 at 10:37 PM, Alexander Sigg said:

Hi guys,

so I did spend the last couple of hours trying out different settings regarding this issue and I came to a conclusion. But first here is what I tried:

Its obvious that turning off mipmap VC in the main menu restores the outside fps back to normal. For me the FPS in the VC stay the same. So far so good you would say, right ?

Well not really. For me personally the VC without the mip mapping is just horrible as shown in a comparison above by me. The shimmering and flickering of the numbers and lines are just not pleasant and hard to watch not even speaking of the effect that the data are less readable than with the mipmapping. Therefore, I can not understand Lefteris point saying Mipmap is unnecessary and makes it even less readable?! I can't say how it looks with a 4K Screen or something in this direction. But I can speak for my normal 1080p resolution and my semi-normal (by now:P) 1080ti.

From here on I thought of two ways to find a solution.

First I tried a different Antialiasing mode to smoothing the edges. So I tried 4xSSAA in the main p3d menu. And guess what? It looks good! Looks even better than 8xMSAA with Mipmap. And the FPS on the outside are about 60FPS (which is due to my Vsync) compared to my 25-30 FPS with 8xMSAA and Mipmap. So you would think it's a good solution for a system like mine with 1080ti. Well I thought so too just to get a bummer shortly after. Going in to any dynamic lighting with the bus makes the FPS drop so badly (15-25 FPS). Not only inside but also on the outside. But this story isn't new. It's been always an issue to get SSAA and dynamic lighting working  together.

Secondly I tried to find an external way to Mipmap the VC panels to maybe trick P3D. But for now I could not find a way. And I also don't think there will be.

So here we/I are. A bit stuck.

I do not know why the bus is doing such thing because I have never seen something quite like it.

I really hope the devs can have a closer look on it because for the average user it's just not pleasant to remain like this. If you have any question regarding this just message me! 

So guys, I hope I could save you some hours of testing and I look forward hearing back from the developers.

Cheers! :rolleyes:

A simple experiment here would be to manually add mip-maps to the VC texture files outside of the sim and keep the VC mip-map setting turned off, it is very easy to do in Photoshop with the Nvidia DDS plugin.

The best option for performance is always to mip-map the texture file and where possible reduce the texture size to the TEXTURE_MAX_LOAD setting (eg 1024x1024). If you do this then the CPU/GPU has nothing to do but load the texture.

One warning - the only problem with mip-maps is the texture file size increases by around 33% which can have an effect on VRAM usage. I'm guessing this is why some developers choose not to mip-map texture files. This is particularly true for very large 2048x2048/4096x4096 files which can be 20mb+ each in size.

Share this post


Link to post
Alexander Sigg
1 minute ago, Lawrence Ashworth said:

A simple experiment here would be to manually add mip-maps to the VC texture files outside of the sim and keep the VC mip-map setting turned off, it is very easy to do in Photoshop with the Nvidia DDS plugin.

The best option for performance is always to mip-map the texture file and where possible reduce the texture size to the TEXTURE_MAX_LOAD setting (eg 1024x1024). If you do this then the CPU/GPU has nothing to do as it doesn't have to mip-map the textures 'in-situ', so you get better performance.

One warning - the only problem with mip-maps is the texture file size increases by around 33% which can have an effect on VRAM usage. I'm guessing this is why some developers choose not to mip-map texture files. This is particularly true for very large 2048x2048/4096x4096 files which can be 20mb+ each in size.

Okay, but I don’t think it’s so easy to mipmap all the VC Screens as they are probably hard to find and not straight forward. Also I don’t want to mipmap the whole VC, just the few screens. I personally think it’s quite impossible but I am always willed to find out better. 

Share this post


Link to post
Danny Moore

I take it the latest update just released does not address the external performance issues reported? 

Share this post


Link to post
Koen Meier
Just now, Danny Moore said:

I take it the latest update just released does not address the external performance issues reported? 

no the update was just to add compatibility with regards to some windows versions. as there is no detailed changelog that is supplied.

  • Like 1

Share this post


Link to post
Hamza Essaadi

I'm also expericning occasional FPS drop but in VC. During cruise specifically

Share this post


Link to post
Tobias Naskrent
On 7/2/2020 at 11:00 PM, Roar Kverneng said:

I have a drop to about 20 FPS in P3dv4 external view....

Same issue here (P3D V4.5 HF3). It's not a LM or P3D thing. The old version runs perfect, so the new built is faulty. No difference between SSAA or MSAA settings. Stutters in VC, extremly bad performance external view. Sorry, but the actual version is not usable.

Share this post


Link to post
Michael O'Halloran
1 hour ago, Tobias Naskrent said:

Same issue here (P3D V4.5 HF3). It's not a LM or P3D thing. The old version runs perfect, so the new built is faulty. No difference between SSAA or MSAA settings. Stutters in VC, extremly bad performance external view. Sorry, but the actual version is not usable.

What’s specs do you have? What you say is identical to me, trying to get as much info as possible to pass it on, it’s very strange how some have an issue and some don’t. 

Share this post


Link to post
Tobias Naskrent
7 minutes ago, Michael O'Halloran said:

What’s specs do you have? What you say is identical to me, trying to get as much info as possible to pass it on, it’s very strange how some have an issue and some don’t. 

i7-8700 cpu, 16GB RAM, Win 10 home, GeForce GTX1080 8 GB VRAM gpu. 

Share this post


Link to post
Khoa Nguyen

Switched to v5 and yes I confirm, external performance is bad, fps gets better when Mip map vc is turned off (Ryzen 3700x + RTX2070S)

Share this post


Link to post
Stefan Vollstedt

Currently you must switch off MipMap AND lock your FPS externally, the internal limiter is still not able to handle it. After these 2 steps the bus runs amazingly!

Share this post


Link to post
Khoa Nguyen

 

1 hour ago, Stefan Vollstedt said:

Currently you must switch off MipMap AND lock your FPS externally, the internal limiter is still not able to handle it. After these 2 steps the bus runs amazingly!

I tried a new test tonight, with MipMap still On and uncheck Dynamic Texture Streaming lock fps at 60fps, and my fps is OK again (around 40fps) on the outside.

So something has to do with Dynamic Texture Streaming ? 

2020-7-7_20-57-25-611.jpg

Share this post


Link to post
Alexander Sigg
7 minutes ago, Khoa Nguyen said:

 

I tried a new test tonight, with MipMap still On and uncheck Dynamic Texture Streaming lock fps at 60fps, and my fps is OK again (around 40fps) on the outside.

So something has to do with Dynamic Texture Streaming ? 

2020-7-7_20-57-25-611.jpg

I never had dynamic texture streaming on and I still have FPS issues on the outside.

Share this post


Link to post
Khoa Nguyen
29 minutes ago, Alexander Sigg said:

I never had dynamic texture streaming on and I still have FPS issues on the outside.

Ok but for me my fps is normal now around 40 - 45 on the outside

Share this post


Link to post
Alexander Sigg
53 minutes ago, Khoa Nguyen said:

Ok but for me my fps is normal now around 40 - 45 on the outside

Well, just the fps are not that bad. Just so many crazy stutters. 

Share this post


Link to post
Ronald Yan

I think I'm down the rabbit hole of unlimited frames and NCP lock vs. in-sim lock again, seems like the discussion has reopened...On another forum: https://www.avsim.com/forums/topic/577360-decreasing-fps/?do=findComment&comment=4265929 this gentleman (another developer) emphasizes the importance of not using external frame lock. Yikes...what's the ordinary P3D flyer to do...sigh

FWIW I use unlimited in sim (v5) with NCP frame lock VC Mips off and didn't really have an issue with the external view framerate.

This Avsim thread seems to claim that v5 has changed the paradigm of the in sim lock? (like others in that thread I'm a bit skeptical, especially with FSL's recommendations in this topic ...) :unsure:

 

Share this post


Link to post
Alex Pugh
21 minutes ago, Ronald Yan said:

I think I'm down the rabbit hole of unlimited frames and NCP lock vs. in-sim lock again, seems like the discussion has reopened...On another forum: https://www.avsim.com/forums/topic/577360-decreasing-fps/?do=findComment&comment=4265929 this gentleman (another developer) emphasizes the importance of not using external frame lock. Yikes...what's the ordinary P3D flyer to do...sigh

FWIW I use unlimited in sim (v5) with NCP frame lock VC Mips off and didn't really have an issue with the external view framerate.

This Avsim thread seems to claim that v5 has changed the paradigm of the in sim lock? (like others in that thread I'm a bit skeptical, especially with FSL's recommendations in this topic ...) :unsure:

Nothing about the internal limiter has changed. Turning it on just means you're telling the sim, "I'd like to sacrifice a third of my FPS to load autogen and textures a little faster." That's pretty much it. This can be fine in a lot of scenarios, but it can be absolutely brutal in others (try unlimited FPS vs. internally locked at LVFR's FLL in the 320... the limiter makes the scenery unusable.) 

Share this post


Link to post
Ronald Yan
1 hour ago, Alex Pugh said:

Nothing about the internal limiter has changed. Turning it on just means you're telling the sim, "I'd like to sacrifice a third of my FPS to load autogen and textures a little faster." That's pretty much it. This can be fine in a lot of scenarios, but it can be absolutely brutal in others (try unlimited FPS vs. internally locked at LVFR's FLL in the 320... the limiter makes the scenery unusable.) 

Just tried it out of curiosity at FT CYYZ; in sim limiter absolutely destroyed my framerate. Not sure what the Avsim guy is on about...I'm sticking with unlimited

Share this post


Link to post
Christian Amadeo Oliveira Araujo

I am using unlimited fps, limiting it externally to 30 and have yet to see it go below that mark (internal and external). VC mipmaps is on btw. Even at flytampa KBOS. i9-9900k, GTX 1070 ti, 32 GB DDR4 3200MHz

Share this post


Link to post
Rob Bates

I get stuttering when in wing views, but only sometimes - seemed to be particularly so in steep turns after TO and in bad weather, which got me thinking - is it one of the FSLabs effects causing it? Perhaps the vortices over the wings, or the haze from engines, or landing lights reflecting on moisture etc....?

Share this post


Link to post

×
×
  • Create New...