Jump to content

Virtual copilot addon


Peter Pukhnoy

Recommended Posts

  • Replies 327
  • Created
  • Last Reply

Top Posters In This Topic

  • Peter Pukhnoy

    127

  • Igor Petrov

    79

  • John Rooum

    17

  • Ju_li_en Ke_ml_er

    14

Top Posters In This Topic

Popular Posts

Beta version with checklists: Copilot 2.0.6.zip Please read the 'Checklists' page in the manual. Human callouts have not yet been recorded, so the callouts are text-to-speech for now (includ

The trigger for the copilot to start waiting for your FMGC setup is the chocks being set. Judging by the log, the chocks are off in the 'on APU' state. Yes - even if you start with the chocks s

I've attached a test version featuring checklists to the opening post.  

Posted Images

Peter Pukhnoy
Just now, Fabian Schankin said:

Yes, as stated by FSL from the very beginning I load the default scenario and then load the FSL Bus

I see, the logic only checks whether you've loaded an FSLabs aircraft upon loading the first aircraft. Loading a default aircraft before FSLabs hasn't been necessary for a very long time.

Link to post
Fabian Schankin
2 minutes ago, Peter Pukhnoy said:

Loading a default aircraft before FSLabs hasn't been necessary for a very long time.

I´ve missed that!

3 minutes ago, Peter Pukhnoy said:

I see, the logic only checks whether you've loaded an FSLabs aircraft upon loading the first aircraft

I´ve tried it again and started the flight directly with the Bus but still no success

Link to post
Peter Pukhnoy
On 4/22/2021 at 10:56 AM, Igor Petrov said:

But I think there's also another problem here: to some reason Win10's speech recognition turns my microphone's sensitivity one notch down occasionally and that's where it fails to recognize.

Now, I've experienced this too. It seems that this behavior is the result of this dialog:

Capture.PNG.db47b3c2a1331fcdbe0f723c18256034.PNG

Whenever an application instantiates a SAPI recognizer, the micorophone level will be turned down if the volume went into the red band when you were reading the phrase.

Link to post

Peter

   On 4/25/2021 at 11:54 AM,  Ju_li_en Ke_ml_er said:

I checked the log and it does recognize the command and execute an action but it won't trigger the flaps in the

Sorry, it's a bug, I'll upload the fix today.

Updated today and problem remains. Under Voice Control, Flaps Up command not recognised - all others ok including flaps down on approach......

john

Link to post
Ju_li_en Ke_ml_er
1 minute ago, John Rooum said:

Peter

   On 4/25/2021 at 11:54 AM,  Ju_li_en Ke_ml_er said:

I checked the log and it does recognize the command and execute an action but it won't trigger the flaps in the

Sorry, it's a bug, I'll upload the fix today.

Updated today and problem remains. Under Voice Control, Flaps Up command not recognised - all others ok including flaps down on approach......

john

the latest version works  for me.

Link to post
Peter Pukhnoy
12 minutes ago, John Rooum said:

Updated today and problem remains. Under Voice Control, Flaps Up command not recognised - all others ok including flaps down on approach......

Which version is that? There are currently two versions (the second one is attached in the opening post).

By 'not recognized' you mean there wasn't even a log message saying 'recognized 'flaps zero''?

Link to post
Peter Pukhnoy
26 minutes ago, John Rooum said:

Which version did you update Peter - the 2.04 or the beta? I just redownloaded 2.04

Both should work just fine. In 2.0.4, I added a speed check: if you're below Vs, the copilot won't retract the flaps. In the beta, I also added a "speed too low" callout for that (at the moment, it's only spoken if text-to-speech is enabled) 

The current configuration should be flaps 1 when you command "flaps zero".

Link to post

×
×
  • Create New...