Jump to content

CTD when pressing Alt+Enter

Mike Ionas

Recommended Posts

I had uninstalled the Concorde when the A320 had come out for P3D as whenever a new version came out it was suggested to remove the FSLabs folder which also contained Concorde files for every re-installation and quite honestly I was focusing on the A320 at the time. Yesterday I decided to re-install Concorde v1.39 having the A320 latest version and spotlights already installed on P3D v3.4 HF2. I loaded the cub followed by the Concorde, but every time I tried to switch to full screen by pressing Alt+Enter, P3D crashed reporting api.dll as the failing module. If I just tried to maximize the window everything seemed to be fine but honestly I never liked windowed mode and never used it (and do not plan to start now). Any idea what might be the problem?

Regardless of the above, is there any required/recommended procedure or sequence to install Concorde, A320 and spotlights? If I just need to update the A320 to a new version do I have to uninstall everything and re-install or just uninstalling/re-installing the A320 will do?

Link to comment

Further testing..

Removed the A320, Concorde and spotlights and removed respective folders.

Installed Concorde v1.39 only. Problem is still there and every time I try to go to full screen I get a CTD as described in the previous post.

Installed spotlights build 33. Now every time I tried to go to full screen, monitor goes blank and after a few moments returns to window mode by itself; strange. After a couple of tries, CTD with the same error.

Uninstall everything. Install Concorde v1.38 by itself. Same problem.

Uninstall everything. Install A320 with spotlights. A320 works fine and I can go to full screen without any issues.

Uninstall everything. Install Concorde v1.39, A320, spotlights. Again, the A320 has no problem with full screen. Concorde always causes a CTD with the following error:

Problem signature:

  Problem Event Name:	APPCRASH

  Application Name:	Prepar3D.exe

  Application Version:

  Application Timestamp:	5851bfd2

  Fault Module Name:	api.dll

  Fault Module Version:

  Fault Module Timestamp:	5851c05c

  Exception Code:	c0000005

  Exception Offset:	001063fc

  OS Version:	6.1.7601.

  Locale ID:	1033

Obviously every installation/uninstallation of each individual module was followed by a system restart, even when not requested by the installer. And after every uninstallation all FSLabs folder leftovers were manually removed. The Concorde was working fine before. I had the version that was available when the A320 for P3D was released but I do not recall the number.

Quite strangely every time I load the Concorde (after the cub as always) a pop up window sound is heard (the default Windows 7 sound), although there is no pop up anywhere, but I do not know if this is relevant..

Any ideas?

Link to comment
Kyprianos Biris

From the installation post, have you excluded the these ? I am sure you have but just asking.



15. Since you have rebooted, the antivirus or blocking software is now active. Go ahead and exclude the following from the antivirus checking process:

  • <Sim>\Simobjects\Airplanes\FSLabs_Bae-Concorde\FSL_ConcX.dll
  • c:\users\<yourname>\appdata\Local\FlightSimLabs folder



Link to comment

It never hurts to double check! ;)

But I do not have AV or anything else relevant in my FS partition and have disabled the default windows Firewall, Defender, etc. The dedicated FS partition is free from any non FS related software.

I do not have MSI Afterburner and the ASUS GPU Tweak II I use does not have an overlay feature (at least not one I can find). The only other overlay I can think of is the Share overlay from GeForce Experience that is disabled.

Link to comment
Ray Proudfoot


I've only had P3D v3.4 a week but I've been in and out of full-screen mode plenty of times and no problem. It sounds graphics related. What resolution are you running at?

Link to comment


I am running at 2560x1440 which is my monitor's native resolution. Funny thing is that I used the Concorde as a benchmark by performing flights between Heathrow and Kennedy to fine tune my setup (which is the same since then). I think the last version I used before the A320 was v1.36, but I cannot be certain. It is for sure the one that was available at the time A320 was released for P3D..

Link to comment
Ray Proudfoot

I suspect that's your problem. Revert to 1920 x 1080 and see if the problem goes away. In any case Lefteris has warned that running at such high resolutions will result in OOMs. This may be another symptom of that resolution.

Link to comment

I will try that later today and get back to you but as I said I was running Concorde at 2560x1440 for a long time without OOMs or any other issues. I even run the A320 at this resolution without any problems whatsoever..

Link to comment
Ray Proudfoot

Well that's interesting Mike because having seen P3D on a 4K monitor at the weekend I'd love to be able to run Concorde at that res. Yours is lower which is perhaps why you don't get OOMs.

One tip I recall from olden days. Always match resolution in Windows and the sim. Fatal to have higher res in full screen mode than Windows.

Link to comment

Of course to achieve this I do not run with all the slider to the max as I am sure you understand :). The reason I used Concorde and the Heathrow/Kennedy route was because it was the heaviest aircraft in my library when I was initially configuring P3D and London and New York are notoriously heavy areas. So it was ideal to balance looks and performance.

Link to comment
Ray Proudfoot


Do you mean error code 2048? Was there no other information? Googling error 2048 returns nothing meaningful.

Try the same action with a default aircraft.

Link to comment
11 hours ago, Ray Proudfoot said:

Try the same action with a default aircraft.

It works fine with all other aircraft, freeware and payware. Only Concorde displays this behavior unfortunately..

Link to comment
Ray Proudfoot
1 hour ago, Mike Ionas said:

It works fine with all other aircraft, freeware and payware. Only Concorde displays this behavior unfortunately..

But only for you it seems. There had to be something not right. When you said res was 1920 x 1080 was that set in both Windows and P3D?

LATER. What changed from when it used to run fine? Have you installed different graphics drivers?

Link to comment

1920x1080 in both windows and P3D, correct. But as I said I never had an issue with the higher resolution, ever..

The only difference apart from installation of updated graphics drivers from time to time was the A320, although even if I uninstall it, still the Concorde does not work in full screen.

Link to comment
Kristoffer Lokke-Sorensen

A long shot, but have you tried:"Edit Prepar3d.cfg and change PANEL_STRETCHING = 1 to PANEL_STRETCHING = 0. Then, start P3D in windowed mode at a lower resolution, load the Concorde-X and then expand to full window mode" ?

The crash might be OOM-related, as the sim increase the size of all the 2D panels accordingly to match the full screen resolution. Worth a try:)

Link to comment


How do you load the 2D panel? Apologies for the "dumb" question but I haven't used a 2D panel since ages.. :wacko:

Link to comment

Ray I cannot thank you enough! :D

It worked! If I go to full screen once with the 2D cockpit loaded, then I can select virtual cockpit and from that point onwards I can switch back an forth in VC mode only.

Thanks!!! Back to supersonic flights once more.

Link to comment

Actually it wasn't that after all..

Sometime back in December I got the MFG Crosswind rudder pedals which were a nice upgrade from the Saitek pedals I was using for quite some time. Because of the following hardware glitch


PC freeze during boot with MFG device plugged in (before you see a windows logo)

Problem is in UEFI bios in a feature called USB hand-off . This feature should provide to Windows all

info regarding connected USB devices during boot, but on certain motherboards it freeze in the process.

It is a bios bug affecting ALL high performance devices which have fast pooling speed (every 10ms or

less ). Affected motherboards (that we are aware of) are those using X79 and X99 chipset, many ASUS

boards afected. Try following solutions :

1. Update your motherboard's BIOS is available as some reported to fix this issue.

2. Check if you can disable USB to OS hand-off in BIOS usb settings. Some motherboards have this


3. Best way is to have all your expensive game perhapial connected to quality USB hub with On/off

button. Will save you some expenses in case of thunder strike or faulty power supply on your PC


documented in the manual, I made a switch to turn the USB connection on and off, instead of having to dive under my desk and plug/unplug them each time. During the 2D cockpit test I had the switch to the off position and this why it worked. Actually it has nothing to do with the 2D cockpit after all. If I start P3D with the rudder pedals disconnected (i.e. switch off) I can go to full screen and then turn them on (i.e. connect them). Everything is fine after that and I can once more go from full to windowed mode and vice versa without any issues.

Go figure..

  • Like 1
Link to comment
  • Create New...