Jump to content

FSL Spotlights causes GPU Driver crash


Benjamin Hennes

Recommended Posts

On 6/22/2017 at 5:21 PM, Lefteris Kalamaras said:

The last answer was not "it's not our problem" exactly - it was "how would we be able to fix something that 1) we don't have the source code for, and 2) exists even when FSLSpotlights is not running / installed".

Do a quick google search for that DXGI issue - it happens everywhere and for lots of DirectX applications - it was introduced with P3D v3.X after 3.3.5 and can occur when the graphics card can not cope with the graphics frame data passed to it.

Sorry Lefteris, It is partly a spotlight problem as rolling back driver / disabling FSL Spotlights fixes the issue

Link to comment
  • 2 months later...
Andrew Greaves

I have been having the same problem, and for the longest time I couldn't figure out the cause of the error. I have found a solution to the problem, but before I get into it, I'm going to list the specifications of my computer, as this solution may not work for everyone.

Intel Core i7-5820K 3.3GHz
32 GB RAM
Windows 10 64 bit
Nvidia Geforce 980 Ti 6GB
Prepar3D V3.4.22.19868

For people with similar specs this may work for you. The cause of the problem is the driver for the graphics card. I have noticed that most driver update are done to accommodate the newly released high FPS games, and they are generally not optimized for flight simulation, at least that's my opinion. So in my opinion it is not necessary to update to every single new driver release unless you are playing other games like Black Ops or any game to that sort.

I did some trial and error and found out that any driver update beyond driver 382.05 will produce the error message. Now this may be just a solution for my system, but I believe it may work for others. However, I can't say for sure that it will work for every video card, but it's worth a try.

If you have updated to the latest driver release, I recommend not to just install on top of the current driver but do a clean installation. 

1. Download driver 382.05 from https://www.geforce.com/drivers

2. Run the installation as administrator

3. When you get to the installation options section, select Custom (Advanced)

4. At the next window select the option that says "Perform a clean installation", and let it complete the process.

A computer restart isn't required, but you can do it if you desire. I did mine without a restart. The key factor is to do a clean installation and test your P3D. Also I did my test with the Fslabs A320 to ensure that higher demands placed on the graphics card will actually work.

I hope this works for you guys, and looking forward to your responses.

  • Like 1
Link to comment
  • 5 weeks later...

I have this same problem and disabling Spotlights in xml.dll fixed it for me too. I'm only using v3 for the Q400 at the moment so I don't need Spotlights. Hopefully it doesn't happen in v4 when the A320X is released for it. 

Link to comment
Norman Blackburn

Hi Ian,

You will be pleased to know that none of us have reported any GPU crashes with Spotlights in v4 or v4.1

On a different note please change your forum name to be your real name. 

Thanks,

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...