Jump to content
Sign in to follow this  
slipstream

FSX Pauses when any function s

Recommended Posts

slipstream

Is it normal?using your driver that FSX pauses momentarily every time I select a push button on the MCP? It is quite annoying. Or is it just me that has this problem? Thanks in advance.

Share this post


Link to post
Lefteris Kalamaras

Hello-

no, that's not normal - can you tell us if you have the driver running under Window mode or full screen, and do you still have the driver dialog window open and/or possibly left the debug checkbox checked?

Share this post


Link to post
slipstream

Ah, debug, I think I may have left it checked. I will have to check and report back. Thanks. smile.gif

Share this post


Link to post
slipstream

Lefteris. How do I uncheck the debug option without re-installing the driver? I cannot see how I?can open the driver dialogue box.?The only option I see is to uninstall the driver. If I do have to uninstall, can you remind me what to back up?

Thanks, Keith.

Share this post


Link to post
Lefteris Kalamaras

Hi Keith-

the driver is accessible through the Addons menu inside FSX - in the FSLabs menu item. If you're running in Full-Screen mode, remember to switch to Windows Mode before trying, because otherwise the window comes up behind the FS display and will be inaccessible.

Share this post


Link to post
slipstream

OK, I start FSX in win mode and then change to full screen as I use multi monitors. I do not have debug selected and I am still getting pauses everytime I select a function.

Any ideas?

Share this post


Link to post
Lefteris Kalamaras

Sorry Keith,

nothing else comes to mind at the moment... How's your frame rate?

Also- does FSX pause momentarily even if you're running in Window Mode?

Share this post


Link to post
slipstream

Yes both, win and full screen. I have excellent frame rates, locked at 40. Tuning an alt or heading is no problem but selecting LNAV VNAV etc then the sim pauses for approx half a second. Very annoying and unrealistic obviously.

?

Share this post


Link to post
Lefteris Kalamaras

Can you try unlocking the frame rates (just a possibility - not really thinking it might be it).

This doesn't happen to others, as far as I am told...

Share this post


Link to post
slipstream

I have tried on unlimited and no change. Its a bit of a mystery really. I will report back on which command inputs it pauses on.

Share this post


Link to post
Flyblue

Unfortunately I am encountering the same pauses.

Basically it happens when I press any of the buttons on the MCP like LVL CHG, CWS A etc.

Also there seems to be occasional polling between FSX and the MCP that causes a short pause as well.

When I disconnect the MCP via the driver and use the MCP via the panel all the pauses are gone.

Regards,

Willem

Share this post


Link to post
Lefteris Kalamaras

Dear Willem and Keith-

could you please try to check with a "virgin" FSX installation that would have only the 747 and the MCPPro driver? Nothing else, if possible (no utilities, not any addons, etc.)

Thanks in advance!

Share this post


Link to post
Flyblue

Hi Lefteris,

Some additional information: I have tried the MCP with the Leveld 767 and the default 737 and the pauses do not occur.

Regarding a virgin installation: That is quite some work and I unfortunately I do not have time to do that now. I will be travelling basically my whole summer as of later this week and will not be returning until mid-august.

If there are any files, dumps etc. that may become handy please let me know and I will send them.

Hopefully Slipstream has time to do the virgin install, otherwise no rush and?we could be picking this up again in August again.

Kind regards,

Willem

Share this post


Link to post
Lefteris Kalamaras

Hi Willem-

can you make sure at least that you're not running any other CPFlight-specific software at the same time? (what do you use to interface with the 767 and default FS aircraft)?

Share this post


Link to post
Flyblue

Hi Lefteris,

I can confirm I have no CPFlight software running. In order to test with the L767 and default 737 I start CPFlight FSCOM manually after I have started FSX, I do not do this when I fly the 747x

For flying the 747X I manually enable the FSLabs driver from within the FSX menu.

I did some more testing:

-De-installed FS2Crew -> No change

-Disabled WideFS -> No change

-Stopped UT2 -> No change

-Disabled AES -> No change

-Flying in areas where I do not have any scenery installed -> No Change

Thanks again,

Willem

Share this post


Link to post
pmpilot

Hi guys :rolleyes:

Now i am not using the MCP Interface from CPflight but using the CDU from Engravity .

But as i read this here i just posting here as it looks like the same problem:

The same thing happens to me if i use the CDU from Engravity , with every Button i push the sim stopps

a short time. ( Only a small time off a second ,but annoying anyway )

You can see it best at outside view.

Normaly with my Installation i have no probs at all.

I see this from beginning i use the driver and as i see the tread here i just tought to post here :huh:

Share this post


Link to post
Jim Driscoll

Any news? this is a show stopper for me.

Share this post


Link to post
KingCat

I've also experienced a very small pause.

When I'm flying on approach with manual control of the throttles, and when I decide to go around, I then engage the autothrottle and select TOGA on my throttle. The small pause occurs when engaging the autothrottle.

Also when disconnecting the autopilot through the disengage bar, you get an aural warning. It's very audible that this sound is played in a loop (you hear the warningsound, then a small pause, and then the warningsound again). This loop isn't audible when using the "software" MCP.

I'm running everything in fullscreen.

Jon

Share this post


Link to post
KingCat

I made another flight, and I can also confirm that the pauses (although small, but noticeable) do occur when pressing buttons on the MCP. I do not have this problem with the FlyEngravity CDU driver. Since several users have reported this "problem", it must be something with the driver. Hopefully a solution will be found.

Jon

Share this post


Link to post
Lefteris Kalamaras

Jon,

it's a known issue and it has to do with the polling nature of the PMDG software. Nothing much can be done on this end.

Share this post


Link to post
Nephi

New here, I came to the forum in search for a solution and I am happy to discover that I am not the only one to have the micro pauses when using PMDG's 747X with CPflight MCP. My pauses occur mostly when switching A/T arm on or off during flight (when going for a manual approach for example), intercepting LOCs and GS, switching from LNAV top HDG SEL or that kind of basic stuff.

1) Any news as to a solution ?

2) also, I read about version 1.02 but I only see version 1.0.0.3 for download on the website ? Where can we find the new version of the driver ? Or was is 1.0.0.2 instead of 1.0.2 that was meant, in which cas 1.0.0.3 is more recent ?

edit : thought I'd give more info on the setup :

i7 920 @ 4,2GHz, 6Go RAM @ 1600MHz, GTX285

PMDG 747X has run flawlessly and without a hickup, no stutters or anything for months now. And bang, I install the MCP, purchase the driver, and microstutters are back and, worse the micro-pauses. At first I didn't even think it could be the MCP so I tried putting down my sliders (not understanding why it was needed all of a sudden) without ANY change : still stutters and pauses, I tried with and without addons... still no joy. And one day I tried a test flight I had been using for months, but this time without the MCP (pure chance : I was cleaning and had to remove the USB plug and forgot to put it back). And there it was again : smooth as silk. I then realised the USB plug was out, put it back in, and stutters and micro-pauses were back. Considering both the price of the MCP and the dirver, I would have hoped to enhance my simming experience, not worsen it :D But I am confident that we'll find a solution, won't we ?

Share this post


Link to post
Nephi

OK I made some additionnal tests today because it is very frustrating to pay 1200 euros for a beautiful piece of hardware and then again 71 euros for a driver not to be able to use it because of the 1 second pauses everytime you push a button or flip a switch.

For the simplest test of all the tests I tried (but I believe also the most telling) I simply put the PMDG 747X on the ground at a mega airport (with vehicles moving included in the airport, but 0% FS airport vehicles and trafic). Then I just switched the "F/D ON" switch on and off

1) first no MCP connected and driver not launched

2) MCP connected but driver not launched

3) MCP connected AND driver launched

4) (more vicious) MCP connected, Driver launched AND then MCP disconnect but without switching off the driver (which doesn't even notice the MCP disconnection by the way !)

The pauses definitely come from the driver ! Results :

1) no stutters, no pause

2) no stutters, no pause

3) stutters and when I flip the switch a 1s (approx) pause

4) stutters and when I flip the switch a 1s (approx) pause

I also monitored CPU acitivity and when I flip the switch there is a short decrease (yes decrease !!) in thread one activity (which is probably the cause for the pause as it runs 100% under normal circumstances) and then, back to 100% activity as the vehicle resumes its movement.

I tried the same 4 tests with autogen gradually back to 0%, weather coveradge gradually back to 0% (cloud density back to 0%), weather distance back to 60NM, etc etc etc. No setting change made any difference at all : the pauses always come when flipping the switch. And actually my FSX was perfectly OK with these settings at max before the driver.

This is extremely frustrating. I hope at least some answer and dialog will establish itself so that we can work this out all together.

Share this post


Link to post
Nephi

Another discovery I made a few moments ago : with the driver on, there is a slight flicker when enlarging the gauges. Usually, without MCP and driver, clicking on the gauges to enlarge them and have a clear look is made instantanously without any problem. Now, with MCP connected and driver on, the enlarged gauge slightly flickers, yes I think it's the best word to describe it. This flicker is only for the enlarged gauge, but not on the remainder of the screen. As if a bus was saturated or something like that. Hope it can help in identifying the problem and solving it. For the moment it is unplayable with the MCP and I have been obliged to disconnect it to be able to fly properly. Hope we find a solution soon as the MCP was a present and I hoped for a better simming experience not a worse :lol: .

Share this post


Link to post
raam123

I bought the driver 4 days ago and I experiencing the same issue of pausing... is there any solution for that ?

Share this post


Link to post
raam123

I bought the driver 4 days ago and I experiencing the same issue of pausing... is there any solution for that ?

No answer since 23.2.13 ?

Share this post


Link to post
raysir1968

:(I just bought the driver 2 days ago. It is so sad that I have the same short-pause problem. I know that I am not the only victim for this issue. Could the official take more responsible about this matter for most of the customers? If they know this problem, why they keep publish this driver to the customers? If anyone can run this driver in PMDG 747X without short-pause problem, please let us know and I want to know what my problem is.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...