Jump to content
>>P.@tr1c_kk@.w@m.ur@

nws ped disco fps drop

Recommended Posts

>>P.@tr1c_kk@.w@m.ur@

just installed the new version, i'm getting 6-7.5fps while the sticky pedal disco button is engaged or when the button is pressed when sticky is off.  otherwise, fps is good.  

any ideas? 

Share this post


Link to post
Bob Lyddy

Is FSX in full screen or window mode?

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

it happens in both full and window modes.  

also, when first loading with the green banner "airbus flight warning computer init..." the fps is 7.5 until it times out.  

 

Share this post


Link to post
Bob Lyddy

I'm not having this low FPS issue. Are you loading from a previously saved flight?  If yes, you cannot with each new update released.  

Post your FSX.CFG file we can review it.

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

pls see attached.   and fresh new flight each time.

didn't see any issue like this before...

just to be sure, manually loaded the dlls and only the fslxxx and unreg fsuipc dlls--same result.

 

 

 

Share this post


Link to post
Lefteris Kalamaras

there is a relative drop in performance when the green message bar is showing, but in all of our test computers the drop is not as pronounced as you describe.

Could it be related to your 4K resolution? Try lowering it to 1920x1080 (temporarily for testing purposes) and let us know if that helps?

Share this post


Link to post
Khoa Nguyen
14 minutes ago, Lefteris Kalamaras said:

there is a relative drop in performance when the green message bar is showing, but in all of our test computers the drop is not as pronounced as you describe.

Could it be related to your 4K resolution? Try lowering it to 1920x1080 (temporarily for testing purposes) and let us know if that helps?

Hi, Thanks for the new update, I haven't tried the new update yet, but people said about its improved performance, great job! I have one question, is this sticky button released automatically on take off? If that is the case, it appears in ur msg that there is a small drop in performance, i  personally wonder is it necessary to have this green msg? What do you think ?

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

ok, i tried 1920 x 1080 and the same result, same low fps.

when the green bar appears for the throttle position, it doesn't affect the frames.

here's a screen grab during the timeout and immediately afterwards.  

 

 a320_fps.jpg

Share this post


Link to post
Lefteris Kalamaras

I'd like to hear from others on this topic too - are you experiencing DRAMATIC (i.e. very significant) perf drops when the green band is showing?

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

Hi Lefteris,

just to reiterate, green band for the throttle position doesn't affect the fps.  

from the bottom, the initial timeout band at 7.5fps, then 30, if throttle is placed in detent, green band shows 30, the top one being when the nws ped disco is pressed.

the previous version didn't exhibit this behavior (for the initial band or throttle).

a320_fps2.jpg

Share this post


Link to post
Lefteris Kalamaras

Are you using any NVidia Inspector frame limiter or any other similar tool?

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

yes, i was running fsx unlimited and 31 limit using nv inspector.  

so... i set fsx limit to 30 and turned off the nv inspector limiter and the result is i now get 23fps avg during the timeout, 29fps avg idle, and about 26/27 avg with the pedal disco is latched.  

so, i guess for whatever reason i shouldn't use the nv insp limiter for this new version, which is ok with me.

 

 

Share this post


Link to post
bluesky

Hi,

i can confirm this. Frame drop from 25 - 30 to exactly 7.5 frames when i press the "," key. FSX Steam in window mode, 1920x1080, loading trike before A320 with engines running.
The green band is flashing (appears for a moment every 2-3 seconds) when i press the "," key and the Sticky function is activated and active.
The green band is only showing once at the beginning when i keep the "," key pressed with Sticky function off.
The green Initialization band is showing all the time during the start phase, but the frames also drop to 7.5. ( I am not sure but i think i hadn't this drop during initialization in the previous version)
Thrust lever detent band is working without frame drop.

If i disable the NVIDIA Inspector frame limiter everything is normal.

Share this post


Link to post
Frank de Witt

I only have the 7.5 FPS in Fullscreen 4K. Window mode works fine.

Share this post


Link to post
Tobias Schmidt

I can confirm the same issue for my setup (FSX fps unlimited but locked external). As soon as the green bar shows up the Frames drop to about 7 fps, otherwise it is very stable at locked 30 fps. 

I haven't tried it without the external frame locking, but undocking the green massage bar, recovers the frames for me as well.

Share this post


Link to post
Dave Woycek

Is there a possibility to disable the green info bars altogether? They've been kind of bugging me since the first release, like the "door arming" messages.

  • Like 1

Share this post


Link to post
Lefteris Kalamaras

We can make that an option for a next update, however are you going to answer support when they come with "waaaaaah - my pedals are stuck!" ? :D

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

Just a feedback on the ped disco sticky option: it works great. I assigned my pinkey switch on the hotas to nws just like for my mil jets. 

 

Share this post


Link to post
Zeljko Budovic

I have same FPS drop with green band - 7.5 fps. I have no problem with this, after loading is finished my fps are 30 most of time. I have FPS locked at 30 using internal FSX limiter and 1/2 vsync in Nvidia Inspector.

Interesting thing, i have same value of 7.5 fps when loading MD11 ;)

Share this post


Link to post
Lefteris Kalamaras

The frame rate drop is not actually due to the A320-X or any other add-on - it has to do with the internal way that Simconnect (and in effect, the simulator) draws text when the SimConnect_Text() function is called and in particular, when it's called repeatedly.

That's why you have the same issue with the MD-11 or, I would bet, with any other add-on that calls that function with specific parameters frequently in the sim update loop.

The NVidia Inspector limiter is obviously adversely affecting this option as well.

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

The fact that the throttle position green status bar hardly degrades frames tells me it's not strictly a rendering issue, but is the thinking now to add an option to turn off the green banners?  Think that will work. 

 

The puritans may disagree but instead of displaying with the simcommect hooks that always causes stutter whenever the text is displayed, add the same info in the icas display (as a user/carrier option)?  

It's another 'sim-ism' for flying on a 2d screen...

Share this post


Link to post
Zeljko Budovic

@kdfw for throttle position green status bar, i belive you can select "visual cues off" in MCDU options. I newer used it, i heard about it first time from you, just now :lol:

We are talking about green band on FSL A320 initialization, this is why i stated i have no problem with that, it's only for a minut when you load the plane in FSX.

I figured out it has to be about simconnect...

Share this post


Link to post
bluesky
25 minutes ago, kdfw said:

The puritans may disagree but instead of displaying with the simcommect hooks that always causes stutter whenever the text is displayed, add the same info in the icas display (as a user/carrier option)?  

It's another 'sim-ism' for flying on a 2d screen...

I really like the idea of a EICAS message, maybe similar to the real world N/W STRG DISC message.

Even if there would be no frames problem i would prefer this solution because it wouldn't be so dominant compared to the green text all over the screen during the whole taxiing.

Share this post


Link to post
Dave Woycek
2 hours ago, Lefteris Kalamaras said:

We can make that an option for a next update, however are you going to answer support when they come with "waaaaaah - my pedals are stuck!" ? :D

No, I'll not come to the forum whining about such thing. I consider myself to be computer literate enough to figure out the obvious.

Should I do it nevertheless, you are entitled to call me names ... :)

So, please, make these messages an option. You can leave them turned on by default, but please give us the possibility to turn them off.

Thank you very much.

Share this post


Link to post
>>P.@tr1c_kk@.w@m.ur@

As indicated earlier, the initial timeout green bar Is accompanied with low fps.  There is no option to turn this off.

 

The throttle position bar does not cause fps decrease.   The bar can be on/off, regardless, not an issue.

 

The nws pedal disco bar displays and fps goes low.   No option to turn this off.

 

So I merely asked if there will be option to turn off all the green bars, or simply display these status on the eicas to avoid using the simconnect call.   Never liked the green bars in all addons, always causes a momentary stutter. 

 

But for now I'll just turn off the nv inspector fps limiter and I'm good to go. 

Share this post


Link to post
Bryan Richards

Here is what I happen when i use the NWS in full screen mode, obviously this makes taxiing difficult when the view is jumping like this, and when i switch to windowed mode, this doesn't happen but my FPS drops from 30 (locked) to 10. Unfortunately, i deleted my previous version, so it looks like no more 320 for me until this is fixed.

 

  • Like 1

Share this post


Link to post
Lefteris Kalamaras

"bgrade"-

are you using an external frame limiter?

Share this post


Link to post
Karl Brooker
4 minutes ago, bgrade said:

Yes i am, i am using nvidia inspector

If you don't use the frame limiter in nVidia inspector, does the problem go away?

Share this post


Link to post
Bryan Richards
Just now, Karl Brooker said:

If you don't use the frame limiter in nVidia inspector, does the problem go away?

I will have to check it when I finish this flight. unless there's another way to get that NWS message to come up while airborne.

Share this post


Link to post
Bryan Richards

I just checked my settings and the Frame Limiter option in nVidia Inspector is set to OFF. I do however had Vertical Sync set to 1/2 Refresh Rate, I will set that to Force Off and see if it makes a difference. 

Share this post


Link to post
Alex Alexeev

I think problem in Ezdock or chase plane , I have this problem in p3d with Concorde, and have solution. In Ezdock you can change simconnect . And after that - all fine in VC.

But on outside view A320 (30 FPS lock in nv ins) it's doesn't work. I have 55-70 FPS on 2-3 seconds and dropping to 7-10 FPS and again. It's look like I have 15 FPS in middle.


Отправлено с моего iPad используя Tapatalk

Share this post


Link to post
adamant365

I can confirm this happens whether in full screen, windowed, sticky on or sticky off. Sitting at my home airport I get 40-50 FPS. As soon as I hit "," it drops to <10 regardless of whether I have the sticky activated or not. I never had this problem before the green box was added for .191. The sticky feature sure is nice, but the FPS hit is large. Maybe as suggested...an option to not have the green box maybe??

I have frames limited to 60 in NVidia Inspector with no vsync option.

 

Share this post


Link to post
Khoa Nguyen

I also experience small drop in fps when the green msg appears, hope it will be an option ON/OFF in next hot fix.

Share this post


Link to post
Chad Bramwell

When not using the sticky option, would it be possible to suppress the message? I'm holding down the comma key, not sure I need a visual reminder of that...^_^

  • Like 4

Share this post


Link to post
Bryan Richards
4 hours ago, Karl Brooker said:

If you don't use the frame limiter in nVidia inspector, does the problem go away?

No the problem is still there, even when returning nvidia settings back to factory stock.

1 hour ago, Yofich said:

I think problem in Ezdock or chase plane

I uninstalled EZDock and this didnt fix it for me.

Share this post


Link to post
Karl Brooker
1 hour ago, adamant365 said:

I can confirm this happens whether in full screen, windowed, sticky on or sticky off. Sitting at my home airport I get 40-50 FPS. As soon as I hit "," it drops to <10 regardless of whether I have the sticky activated or not. I never had this problem before the green box was added for .191. The sticky feature sure is nice, but the FPS hit is large. Maybe as suggested...an option to not have the green box maybe??

I have frames limited to 60 in NVidia Inspector with no vsync option.

 

Would you be willing to try with the frames unlimited in nVidia and see if this makes a difference for you?

Share this post


Link to post
NilsUnger
45 minutes ago, JetJock said:

When not using the sticky option, would it be possible to suppress the message? I'm holding down the comma key, not sure I need a visual reminder of that...^_^

That's true! :lol:

Share this post


Link to post
Maurício Brentano

I can confirm the fps drops by half with the steering button pressed when NVInspector Vsync (1/2 refresh rate) is ON. With it turned off I have a minimal fps drop.

Share this post


Link to post
adamant365
33 minutes ago, Karl Brooker said:

Would you be willing to try with the frames unlimited in nVidia and see if this makes a difference for you?

With frame limiter off, the FPS drop is more modest. Starting at 28FPS, dropping to 20. But for whatever reason, my overall FPS are lower with the limiter off: 24-28 vs 45+ with it on. 

Share this post


Link to post
Théo ALDEGUER

Hi,

When i push the comma key to get the tiller working, i got a message highlighted in green saying the comma key is pushed or something like that. The probleme is that this message make my fps drop almost to 0 et the image is shaking every time I push the coma key or when a FSL message is displayed. it Does the same on initial loading.

 

Is there any way to remove those displayed messages, especially the one when using the comma key ?

 

with 191 i'm also unable to get back ti my desktop with window key...

Share this post


Link to post
Lefteris Kalamaras

Gents-

Edit your <sim>\FSLabs\A320XGauges.ini file and add

[Tiller]
PedalDiscBtnStickyDrawNotice=0

Let me know if that helps - it should no longer display the green bar with the text on top. Just remember that if you do remove the green bar notice, you'll have to remember whether you've activated the comma key or not (if you have made it sticky, that is).

  • Like 6

Share this post


Link to post
Rafal Haczek

The above A320XGauges.dll entry does the trick for me.
Before I had about 5 FPS drop with the tiller, now I think there is none (maybe 1).

Another nice thing I've noticed, by the way, is no more errors on FSX exit (and none on loading the bus yet). :)

But I haven't seen any FPS improvements in general.
I am not sure we were supposed to expect any though.

  • Like 1

Share this post


Link to post
Bryan Richards
1 hour ago, Lefteris Kalamaras said:

Gents-

Edit your <sim>\FSLabs\A320XGauges.ini file and add




[Tiller]

PedalDiscBtnStickyDrawNotice=0

Let me know if that helps - it should no longer display the green bar with the text on top. Just remember that if you do remove the green bar notice, you'll have to remember whether you've activated the comma key or not (if you have made it sticky, that is).

This works for me as well, thank you.

Share this post


Link to post
adamant365

Simply brilliant Lefteris (and the whole FSLabs Dev Team) to have a software switch already coded to remove that green box. I can return to my FPS limit of 60 which overall improves my FPS and smoothness...go figure. It works perfectly. Just tested it with my original "default" NVI limit of 60 FPS and it works! And I get to use the awesome "sticky" to free my keyboard for other tasks during preflight/taxi. Thanks again, great stuff here.

Share this post


Link to post

×
×
  • Create New...